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License

This work is licensed under a Creative Commons License. Visit 
http://creativecommons.org/licenses/by-nc-sa/2.5/ for details.

 
Attribution-NonCommercial-ShareAlike 2.5 

You are free:

• to copy, distribute, display, and perform the work 
• to make derivative works 

Under the following conditions:

Attribution. You must attribute the work in the manner 
specified by the author or licensor.

Noncommercial. You may not use this work for commercial 
purposes.

Share Alike. If you alter, transform, or build upon this work, 
you may distribute the resulting work only under a license 
identical to this one.

• For any reuse or distribution, you must make clear to others the license terms of 
this work. 

• Any of these conditions can be waived if you get permission from the copyright 
holder. 

Your fair use and other rights are in no way affected by the above.

This is a human-readable summary of the Legal Code (the full license)  1  . 

Disclaimer  2  

1 http://creativecommons.org/licenses/by-nc-sa/2.5/legalcode
2 http://creativecommons.org/licenses/disclaimer-popup?lang=None

HowTo Build with Crystal Space and Blender - License

http://creativecommons.org/licenses/by-nc-sa/2.0/
http://creativecommons.org/licenses/disclaimer-popup?lang=None
http://creativecommons.org/licenses/disclaimer-popup?lang=None
http://creativecommons.org/licenses/by-nc-sa/2.5/legalcode
http://creativecommons.org/licenses/by-nc-sa/2.5/legalcode
http://creativecommons.org/licenses/by-nc-sa/2.5/


Intro

The first version of this tutorial used a number of tools - GtkRadiant, Blender, Gimp, 
blender2cal3d and map2cs. This revision shifts things around to match how Crystal Core 
development is proceeding, using a more streamlined toolset. Blender is used for both 
model and map building now with Gimp is still used for textures design.

The toughest part of a massive project like creating an interactive space is finding all the 
tools to get started. As we proceed through the tutorial all data, entities and code will be 
created from scratch (well... as much as possible...). The idea is to give you, the 
formidable Crystal Space powerhouse you are, an idea of the resources needed to 
complete a project. Getting a working toolchain running is always half the battle - 
hopefully this doc will cut some of that initial setup time down.

This document is separated out into two sections: creating artwork for Crystal Space and 
coding a standalone Crystal Space application. In the first section we won't even open an 
IDE – we will use our toolkit to create levels, character models and sound then test it 
using the default Crystal Space utilities. The second section will load and manage these 
entities within an independent application.

Our Formidable Goal
Every project needs an end goal in mind. A moment where you can finally throw up your 
arms, cry “I'm done!” and pass out on your desk, lobbing your forehead directly into the 
keyboard. Here's our project goal:

“Design an interactive, third-person scene where some entity will run around a room 
and knock things over.”

Also known as “A Day in My Life.” It sounds stupid, but think of the subject areas we 
should cover to complete this primitive scenario:

• Setting up a development environment • Camera movement
• Map building • Collision detection
• Model building • Model interaction
• Animation • Physics
• Texture mapping • Building a stand-alone application

Thanks To

Thanks to Jorrit and Sunshine for Crystal Space. I encourage everyone to donate early, 
donate often to the project. Lego's aren't free, people.

Thanks to the entire Blender3d crew for the freedom that Blender now enjoys. Buy all 
their books. They make great gifts.

Thanks to Gregor, Jiba, Bjørn and Pablo for their respective Blender conversion tools.
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Starting Out

What you should already know
You should already know C/C++ and be very comfortable with an object-oriented 
architecture. A working knowledge of structs, classes, dereferencing pointers and memory 
allocation is a must. You also need to be fairly comfortable with running command line 
scripts and whatnot.

Some artistic talent is helpful, but not altogether necessary. Hell, I made it this far.

Style and Code Conventions
Typing out code in book form and having it become somewhat readable isn't easy. For 
convention sake, new code that we're creating is green and italic, previous code that 
we are now removing is red with a strike-through and code that we're just 
reiterating for clarity's sake (but we are not creating or removing) is just preformatted 
text.

Getting your toolkit together
Before you can start your Crystal Space hackin', you need a suite of software. Here's a list 
of the items you should bring to class. Note that the majority is open source and freely 
available on multiple platforms.

• The latest version of Crystal Space from CVS. This tutorial will use the most recent 
version checked out at 10/25/2005.

• The latest version of Crystal Entity Layer, or CEL, from CVS. This tutorial will use 
the version as of 10/25/2005.

• Blender   2.3.7a  . The scripts we'll use require this version or later.

• The application blender2crystal for converting our Blender objects to Crystal Space 
meshes. This tutorial will use the CVS version from 11/10/2005.

• The GIMP. This application allows us to create textures and images for use with 
Blender and Crystal Space.

• A C/C++ development environment for your platform, such as Visual C++, Visual 
Studio, KDevelop, Emacs, Borland C++, a text editor and a copy of gcc, whatever 
tickles your respective fancy.

Recommended items
There are a few items that, although not completely required, I've found pretty helpful:

• The Official Blender 2.3 Guide. It covers version 2.31 and is an invaluable way to start 
learning about animation, materials, lighting, mesh design, etc. Having a nice, glossy 
book can be extremely helpful.

• I hear both Grokking the GIMP and GIMP: The Official Handbook are nice lil' books 
to learn about working with GIMP. I haven't read 'em, but as far as books go, they are 
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definitely some of the bookish books out there. They're available in both online and 
printed form.

• Salada Green Tea  . Savory.

• Somewhat recent hardware. A P4 2.4 GHz or an Athlon XP 2100+ with 512 RAM and 
a modest 3D accelerator (GeForce 4Ti or similar ATI hardware). Some shader effects 
in Crystal Space need more modern cards, but we won't be covering shaders in this 
tutorial.

• A high resolution monitor. 1280x1024 is a workable resolution – the more the better 
when dealing with Blender workspaces. Multiple monitors may or may not be a big 
help, since some video cards can have problems doing multi-monitor displays and 3D 
acceleration.

• SuSE Linux 9.3 Professional or better. I'm not being an evangelist here; I just think 
this is the easiest platform for your primary development. You can port to Windows 
after originally writing of Crystal Space applications in Linux - so you don't have to be 
so concerned with your development environment matching your target environment. 
The main reason I like Linux development is because so much of the distribution is 
geared towards allowing extensible compilation, development tools, debugging, 
memory allocation tools and automation. Considering that Linux distributions rely on 
the fact that source is readily available for people to compile and build themselves, 
they make it very easy to develop, compile and test code in a myriad of ways.
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Homework Assignment #1

Before we begin with GIMP, take a few moments just to mess around with the features. 
Create a random image, use all the filters, use all the Script-Fu plugins. Randomly 
stumbling upon some combination of filters or interesting seeds into a plugin can create 
some interesting art.

1. Find an easy way to create a red and blue grid

2. Find the Fractal Explorer and dork around with it. It's nifty
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Building Textures for GIMP

Textures can be anything – squiggly lines you sketch, a scanned-in image, a digital 
photograph or some procedurally (or programatically) generated. The tough part is trying 
to find a way to make textures look “smooth” without seams or abrupt edges. No matter if 
its on a character model or a wall on a map, you need to ensure your textures can reoccur 
and not look to jarring next to adjacent textures.

The easiest way to do this is by building a pattern for GIMP, then applying this pattern to 
a larger image. Patterns are just small images that are specially designed to reoccur – such 
as bubbles or a tartan pattern might repeat across someone's desktop. By using patterns 
we can build better textures without having to manually match up seams against seams.

Starting With an Image
Let's start with a random digital image of carpet. Initially it looks awful – there are large 
occluding shadows, light is uneven and its bigger than what we need. Our first step is to 
crop our image so we just have the content we like. It's best of our proportions are equal 
and our image width and height is a power of two, such as 768x768. This will allow us to 
more efficiently use the image when applying it as a texture to a 3D mesh.

Next, scale your image down to a reasonable size less than 512 pixels wide. For this 
purpose, we'll just use an image size of 128x128 pixels.

Next, chose Filters→Map→Make Seamless. You'll notice that the corners of the image 
turn inward a bit and the edges become a bit altered. It may not at first look like it, but 
GIMP has magically adjusted your image so that multiple copies of this image tiled 
together will look like a single, seamless carpet. Go ahead and try it out!

Creating GIMP Patterns
Now we're ready to use this image as a GIMP pattern. Find your GIMP user settings 
directory – either ~/.gimp-2.2 in Linux or somewhere in C:\Documents and 
Settings\Username in Windows. Save the image as a GIMP pattern (*.pat) in your user 
settings directory within the patterns/ folder. For example, I saved mine as 
~/.gimp-2.2/patterns/carpet.pat.

Once your file is saved, open up your patterns dialog in GIMP (Shift+Ctrl+P). Hit the 
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refresh icon at the bottom-right hand corner, and you should see your new pattern pop up 
in the list.

Create a new image of any size then use the bucket fill to fill the entire image with your 
new pattern. Ensure that it looks consistent and seamless throughout. Your eye will 
probably notice some reoccurring patterns in the image – if you wish, now is the time to 
even the pattern out or even make it more prevalent. For example, a carpet should be even 
in texture across the image, but ceramic tile should definitely have repeating sequences.

Applications
This same technique should be applied whenever you need a uniform texture, such as 
with hair, skin, concrete, floors, etc. Using GIMP's many filters, plugins, effects and 
distorts you can even start an image from scratch then create a realistic material pattern.
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Homework Assignment #2

This is the biggest hurdle to overcome: setting up your dev environment, installing all the 
apps, getting the first app compiled. Use the below documentation to compile Crystal 
Space and send it through a test run.

1. Build and install   Crystal Space

2. Run the Crystal Space Walktest application
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Build a Map from Scratch

We aren't even going to start with Blender on this one... our first level is going to be done 
entirely by hand. Map data is stored in XML format, then usually archived to a smaller 
size later. This can make map loading potentially slow, but very extensible and easy to 
modify.

Let's start by sketching out what we want our map to look like in three-dimensional 
space. It should just be a small box, 20x20x203. The intersection of the x and z axis will 
be the center of our floor, so the width dimensions will be from -10 to 10, depth from 10 
to -10 and height from 0 to 20.

Creating Textures
We'll also need a texture to cover our walls with. Any 64x64 pixel image will do – I fired 
up GIMP and created a really quick texture using one of GIMP's default patterns as 
explained in the preceding section Building Textures for GIMP. The resulting tile-looking 
image is saved as amethyst.jpg.

Creating the World Map

Defining the Map in XML
Now that we have some paint, we need some walls. A Crystal Space map file is just an 
XML document, so fire up your handy ol' text editor and start typing. Create a file called 

3 Note we don't really have a unit of measurement... it's largely subjective. You'll get a feel for what a unit 
is after running around in a few maps. Jorrit's rule of thumb is that 1 unit in CS equals 1 meter. Awith 
Blender 2.35 player character might average 0.6 units wide, 0.3 deep and 1.75 high.
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“world” and type the following headers:

<world>
  <plugins>
    <plugin name="thing">crystalspace.mesh.loader.thing</plugin>
  </plugins>
This tells the Crystal Space engine to load up the thing plugin, used for creating thing 
meshes. Things are basically only used for really big structures (such as maps).

Now that we have our plugin loaded, we'll need to add:

  <textures>
    <texture name="amethyst">
      <file>amethyst.jpg</file>
    </texture>
  </textures>
  <materials>
    <material name="defaultWall">
      <texture>amethyst</texture>
    </material>
  </materials>
This loads our graphics file and gives it an alias – in this case the texture in file 
amethyst.jpg is saved as texture amethyst. The texture is then loaded into a material for an 
object, in this case we load the amethyst texture as the material defaultWall. These 
references make it easy to re-use textures as necessary and quickly change paths or 
textures if we need to.

Next up let's send the engine a command to clear the screen and the z-buffer:

  <settings>
    <clearzbuf>yes</clearzbuf>
    <clearscreen>yes</clearscreen>
  </settings>
After this we set the camera's origin – where we initially spawn when the map is loaded. 
We'll lauch a few feet from the floor towards a corner of the room:
  <start name="Camera">
    <sector>Scene</sector>
    <position x="5" y="5" z="-5"/>
  </start>
Easy so far. Now let's create our room's geometry.

Crystal Space divides maps into sectors for more efficient loading. Sectors can be joined 
together by portals, which basically “teleport” you from one sector to the next.

We'll just have a single sector, since our room is simple and small. Let's define it as 
“Scene” (this will have special meaning when we start doing Blender stuff).
  <sector name="Scene">
Now let's place a light towards the top of the room. Otherwise you'll stumble around until 
you kick the cat:

    <light name="Lamp">
      <center x="0" y="15" z="0"/>
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      <color red="1" green="1" blue="1"/>
      <radius>30</radius>
    </light>
Now we actually define the planes surrounding us. We'll call it “Room” and list its 
individual vertexes. 

    <meshobj name="Room">
      <plugin>thing</plugin>
      <params>
        <v x="10" y="0" z="10"/>
        <v x="10" y="0" z="-10"/>
        <v x="-10" y="0" z="-10"/>
        <v x="-10" y="0" z="10"/>
        <v x="10" y="20" z="10"/>
        <v x="10" y="20" z="-10"/>
        <v x="-10" y="20" z="-10"/>
        <v x="-10" y="20" z="10"/>
Excellent. We've called our thing mesh plugin and given it our list of eight vertexes, one 
for each corner of the box we'll launch our camera into. Now we need to paint our walls... 
otherwise it's hard to see 'em.

We'll be using UV texture mapping for the walls, mainly so we can become familiar with 
the concept once we start using Blender. The “uv” part comes from the two dimensions of 
our texture. Since the coordinate spaces x and y are already used by our object, we'll refer 
to the horizontal and vertical dimensions of our two-dimensional texture as u and v.

Below you can see a list of vertexes which are then mapped to the texture we created. The 
u and v coordinates are between 1 and 0 – so below we are mapping the whole texture to 
a given face.
        <p>
          <v>1</v>
          <v>2</v>
          <v>3</v>
          <v>0</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
        <p>
          <v>7</v>
          <v>3</v>
          <v>2</v>
          <v>6</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
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        <p>
          <v>5</v>
          <v>1</v>
          <v>0</v>
          <v>4</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
        <p>
          <v>5</v>
          <v>6</v>
          <v>2</v>
          <v>1</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
        <p>
          <v>7</v>
          <v>4</v>
          <v>0</v>
          <v>3</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
        <p>
          <v>4</v>
          <v>7</v>
          <v>6</v>
          <v>5</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
      </params>
Let's close up all our tags!

    </meshobj>
  </sector>
</world>
with Blender 2.35And believe it or not, that's it! Save the file in the same directory your 
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texture exists.

Testing the Map
Crystal Space ships with walktest, an application that loads up maps and lets you jaunt 
through them. Hopefully you should have Crystal Space up and running and have already 
run walktest. Generally if you have any problems with Crystal Space, the first response to 
your inquiries is “does walktest run?” Take a moment to run and walkthrough walktest to 
see what its like.

We're going to load the map in walktest using a few commands. Because we need 
walktest to recalculate lightmaps for us (since this is a new map), we need to use the 
-relight command. This will give us a lightmap cache that we can reuse later. We'll also 
run -verbose to printout lots of debug info should we need it.

If your machine doesn't have hardware acceleration enabled (i.e. you're using Xinerama 
like me) you'll need to add the parameter -video=software to the command as well.

Let's say the map and the texture are in my current directory. To load the level up and 
walkthrough it, type

walktest -relight -verbose .

This should load your map and allow you to run through it4

4 The 0 key will launch a rocket from the camera's location and explode upon impact with a wall
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Homework Assignment #3

Now we're gonna use Blender to help us with the level building process.

1. Read the Introduction to Blender  5  , but skip “Your First Animation in 30 Minutes” if 
you like

2. Complete Part 1 of the blend2cs tutorial  6   with Blender 2.35

5 http://download.blender.org/documentation/html/book1.html  
6 http://www-poleia.lip6.fr/~degris/blender/tutorial/  
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Build a Map with Blender

Now we'll construct the same map, except this time with Blender. One word of warning 
when using Blender to create Crystal Space maps: don't rotate or scale meshes in object  
mode! Instead use edit mode to scale and rotate selected vertexes. Failure to do so can 
cause some wacky texture warping and shearing7.

Creating the Box
First we need to create the 20x20x20 box. Go to Add→Mesh→Cube to add a cube at the 
current cursor. Make sure you're in edit mode, then select all the vertexes of the cube; you 
can do this using box select (B key) or doing a select all (A key). After that, scale your 
cube (using the S key) to be roughly 20 units high, wide and deep. Use the CTRL key to 
snap your vertexes to the grid – it can help you keep things evened up. Bear in mind the 
fine grid lines mark off single units, the bold grid lines mark off ten units.

To move your box above the x and z axis, grab your vertexes (G key) and move them up 
toward the top. Switch top, side, front and free view modes to ensure you have a nice 20-
unit cube.

Next we add our texture to the cube. Switch to the material screen (drop down SRC list at 
the top of the screen). In the toolbar on the right, switch to the UV editor (Shift-F10) then 
go to Image→Open... to open the file dialog. In the dialog window, ensure that you have 
the “Relative Paths” button selected8. After that, open up your image file into the UV 
editor.

7 From the Crystal Core Creating Art article on the Crystal Space site: “Warning! In Blender it is best to 
scale and rotate objects in edit mode (by scaling/rotating all vertices) instead of directly on the object. 
The reason is that in the latter case blend2cs will generate a scale/rotate in the world file on the mesh 
object. In case of the rotate this is not that bad but it is illegal to scale objects in CS using <move> 
(using <hardmove> is ok). If you already scaled objects directly you can use 'Apply Size/Rotation' (ctrl-
A) in blender to fix this. This even works with all objects selected at once.”

8 Versions after 2.34 have a very handy “Relative Paths” button in the file open dialog. This will allow 
Blender files to be much more portable, since currently all file paths are stored as absolute pathnames. 
For example, if you open an image in /home/user/image.png, save the .blend file and move it to another 
computer, the image on the other computer must also be located at exactly /home/user/image.png. 
Newer versions released will remember where the file was located relative to the .blend file instead, 
allowing a directory to be easily shared and moved from workstation to workstation.
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Jump into UV Face Select mode. Select each face of the cube and add the texture to it by 
selecting it from the drop-down texture list.
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Switch back to model view. Right now our cube faces are pointed outward – so when 
we're inside the cube we'll see nothing but infinite space. We need to flip them around so 
we can see them inside the cube. It's like the faces of a playing card – only one side is 
printed, the other is just random crapola.

Go to edit mode, open up the buttons menu and switch to the editing layout (F9). Click 
on “Draw Normals” and increase NSize from 0.100 to 1.000. Note lines are pointing 
outwards – that is the faces are pointing outward. Select all the nodes, then click on “Flip 
Normals.”

Make sure to place a camera object and a light within our cube as well. Both should be 
placed towards the center of the cube.

Exporting the Blender File
Use blender2cs to export our Blender level to a Crystal Space XML world file:
blender2cs tutorial.blend -o world

Take a look at the resulting world file that's produced. Looks pretty similar to the one we 
created by hand, doesn't it? Aside from some rounding, the values should be fairly 
similar. Load it just as we loaded the first world file, using
walktest -relight -verbose .
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That's it! The camera object we placed in the center of the cube has become our start 
point, the light object we placed in the cube was translated into a light source for the map, 
and the inverted faces of our cube were mapped into vertexes for our room.
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Homework Assignment #4

1. Complete Part 3 of the blend2cs tutorial  9  .

2. Expand your map into something more creative and sizable – we need room for some 
objects to be tossed around.

9 http://www-poleia.lip6.fr/~degris/blender/tutorial/  
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Object Library Loading in Maps

In refining your custom map you might have had several reoccurring objects (such as 
furniture) that would be easier to load from a single source instead of copying-and-
pasting the object multiple times. This can be done by creating an object in its own .blend 
file and then referencing it within Blender.
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Homework Assignment #5

We're going to start building character models, so it's time to:

1. Install blender2crystal10. Depending on if you already have Python installed and what 
platform you'll be running Blender on, you might have to install some additional 
Python modules or install an isolated version of Python that's Blender-centric. Consult 
Appendix B for a guide on how to create a separate Python installation for Blender in 
Linux.

2. Complete “Your First Animation in 30 Minutes” in the Introduction to Blender  11   
documentation you read earlier

10 http://b2cs.delcorp.org  
11 http://download.blender.org/documentation/html/book1.html  
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Building a Character Mesh in Blender

Building an animated, texture-mapped character for use in a 3D engine can be a daunting 
task. Here we're going to walk through building a low-polygon human mesh from 
scratch... using no external resources. We'll build the wireframe itself, map it with 
textures of our own design, animate it to our liking and export it for use in Crystal Space.

Creating Reference Images
Before you actually create a mesh in Blender, you need to create reference images that we 
can use to judge size and proportion. If you're an artist and have the ability for figure 
drawing, do a brief sketch of your character. This is where concept art really comes into 
play; the better initial concept art you have to draw from, the better your resulting image 
is.

If, as is my case, you can't draw a freakin' cube to save your life, you can instead use 
reference images. 3D.sk12 is one repository for human photo references, and if you need 
detailed modeling for tons of human mesh targets then this is a great one-stop shop 
(especially for those pesky hands, feet and heads). Of course you could always take the 
old-fashioned route and take the reference photos yourself – just make sure that the 
camera is about chest level to the subject and they are wearing either form-fitting clothing 
or none at all13 (otherwise we'll be tracing the outfit instead of the actual human form).

Subjects should have their arms out, parallel to the ground. Feet should be a relaxed 
distance apart, as if they just stopped walking. Head should be looking straight forward, 
spine should be straightened. A few examples are provided in Illustration 8 where I 
grabbed images from some random sources, removed the negative space around them and 
then created a border around the figure itself in GIMP. Sometimes it helps just to have the 
border so you can define the bounds of a mesh, sometimes it's helpful to show all the 
detail of the image so you can define individual features. Experiment with either one and 
see if you find the additional detail distracting or not.

No matter if you sketch or photograph, you'll need at least one hand, one foot, one front 
full body view, one side profile full body view, one front head view and one side profile 
head view. 

12 http://www.3d.sk/  
13 I see that smirk! This is art, people! Have some respect!
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Building the Torso and Limbs of the Mesh
Now that you have reference images you can start defining your base mesh. Wipe your 
slate clean of any initial objects Blender may load up so that we're starting with no items. 
Click on View→Background Image in the drop-down menu list of the 3D Window you 
are currently using. Load up your forward-facing reference image into Blender so it loads 
in the background. Units really aren't all that important at this stage in the game, but I 
usually scale the image down to be two units high and move the Y Offset up so the 
image's feet are right at the Z axis14.

14 A few people are confused by Blender's definition of the X, Y and Z axis in the 3D Window. Most 
people are trained that the Z axis goes into and out of the screen (i.e. the Z axis goes towards and away 
the viewer looking at the monitor), but Blender's Z axis goes straight up and down. Y goes back and 
front, then X goes side to side (as normal). If this gets too confusing you can use the Shift key to cause 
keystrokes to follow the original mentality (i.e. Shift-Z selects the Y axis, Shift-Y selects the Z axis).
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Now that we have a reference image to work off of, we can start adding objects. Our 
method of building character a mesh will be a lot like how figure drawing is done on 
paper or canvas – we'll start with some primitive shapes, join them together then 
individually tweak them to resemble or background image.

Let's start by adding 8-sided cylinders for our torso, arms and legs. Go to top view 
(Num7) add add a cylinder in Edit mode15 using Space→Add→Cylinder. Change the 
vertex value to 8 so Blender will drop in an eight-sided cylinder. Place the center of the 
cylinder directly at the intersection of the X and Y axis (if it's not there already), and scale 
it until it is approximately the size of our reference image's torso.

Switch to a front view (Num1) and scale the cylinder again so that it's the same height and 
width of our subject's torso. Your object should be as wide as the shoulders and reach 
from the neck to the hips (see Illustration 10).

15 In fact, it's good to do everything in edit mode. Switching to object mode is nice when you're working 
on multiple objects in a scene or when you want relative transformations, but since we're building a 
single object we want absolute transformations and single object references.
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Once your torso is set and while still in Edit Mode, add a cylinder for the left arm (we'll 
worry about the right arm later). Switch to side view (Num3) and add yet another 8 vertex 
cylinder, this time about the girth of the subject's arm. Switch back to front view, then 
move the cylinder to the middle of the subjects arm. Scale along the X and Z axis as 
needed until your cylinder is about the length and width of your image's arm.

Perform the same type of operations to create a cylinder for the left leg as well. Once you 
have both left limbs created as cylinders alongside the torso, switch to a wireframe view 
(Drawtype→Wireframe) so you can view the reference image underneath your object 
primitives.

Now we can start subdividing the mesh and have more vertexes to play with. Use CTRL-
R to perform a loop subdivide anywhere on the cylinder and basically cut a line between 
vertexes in half. Make these cuts whenever your reference image tends to need additional 
definition such as around the biceps, around joints and after the ribcage.

Before you start tweaking individual vertexes, however, join the shoulders and the hips 
together at the torso. Find the flat end of the cylinder that is closest to the torso. Select the 
center vertex of the circle that exists at the end of the arm and leg cylinders, then delete 
them. This will delete all the surrounding faces and leave you with an “open-ended” 
cylinder that has an open end on one side, a closed end on the other.
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Illustration 14 shows how a corresponding “entry point” into the torso is created: we pick 
two faces close to our shoulder joint, then delete them in order to open up our mesh. Now 
we should have two open meshes – one open-ended cylinder for the arm and one 
matching open-faced polyhedron at the side of the torso. We need to close both of these 
meshes and leave no empty faces by joining them together.

Scale the vertexes that surround the open end of your cylinder until they overlap the 
opening in the torso's shoulder joint. While keeping in a strictly front or side view in your 
3D window, grab and move individual arm vertexes onto the shoulder so that each point 
in the arm overlaps with a corresponding vertex on the torso. Don't use freelook when 
trying to get vertexes to match up – your depth perception can be completely off when 
you're moving things around in 3D coordinate space. Stick to your front, side or top views 
only. Once you've subdivided your mesh correctly, you should have exactly eight vertexes 
on your arm placed right on top of eight vertexes on the torso.
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Once the vertexes have been perfectly placed on top of each other, border select all 16 of 
them. Once they have all been selected and are currently highlighted, use the “Rem 
Doubles” button in Blender to fuse them together. You may need to experiment with the 
Limit: parameter that sets the threshold on how close two vertexes must be before they 
can be joined together – just try Rem Doubles and then use CTRL-Z to undo the action if 
you removed too many or too few vertexes. You'll know your two meshes have been 
correctly joined if you see a message saying “Removed: 8” and your mesh looks 
otherwise identical.

Let me forewarn you: you don't want to have any open faces in your mesh... otherwise 
you can get some very nasty leaks. These problems will become evident later on in the 
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process as you encounter all sorts of rendering and animation bugs, so do your best to 
avoid them now and ensure all your meshes are joined together. If you leave any open 
faces or holes in your mesh, you may be headed for disaster down the road.

Once you are confident that your arm has been fused with the torso, perform the same 
action with the leg. Delete the for four faces on your figure's left side where the torso will 
meet the leg, then join the two sets of vertexes together. Remember to scale your open 
vertexes to match up with your torso, then only grab and move vertexes while strictly in 
front, side or top view modes. Be sure to save your file up to this point – and slap yourself 
if you forgot to do so yet. Even Blender's undo feature has limits.

Now that we've joined together our limbs, we can start tweaking the individual 
subdivisions in our mesh. You can change any vertex you like on the left side of your 
mesh – but don't tweak the X coordinate orientation of your center-most vertexes of the 
torso. Be sure you don't shift your central “line” of vertexes either left or right – keep 
them dead center. 

To tweak our allowed vertexes, use Blender's border select key (B key) in a wireframe 
edit mode, grab the “rings” which subdivides one of our original cylinders and start 
scaling it to better match the scale of your background image. Also feel free to rotate 
these “rings” of subdivision so they better match the creases and curvature of your 
subject. You should move from a blocky, three-cylinder mesh to something much more 
akin to a human layout. Bear in mind we're only focusing on the left side of the body right 
now, and we are skipping the hands and feet for the time being16.

Be sure and switch to a side view as well, so your constraints also apply to the subject's 
profile. In this instance it's very handy to have a side-view reference image, since spine 
curvatures can sometimes be tough to mimic without your corresponding background 
image to help you.

Now that we have our basic trunk finished, let's go ahead and delete all the extraneous 
vertexes on the right side of the mesh. Border select the vertexes that exist solely on the 
right side of the body, then delete them with the X key.

16 They're, like, hard and stuff.
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Building the Hands
Hands, feet and heads are tough subjects, so we'll cover them separately. In fact, we 
should even create them separately. Switch to Object Mode and change to another layer in 
your scene. This new layer should be a blank slate with which we can focus entirely on 
creating a left hand.

Going back to using primitives to describe our more organic meshes, we're going to be 
using two different types of shapes: a cylinder and a disc. Our disc is, in fact, just a really 
flat cylinder oriented on a different axis... so we will be sticking to the same methodology 
we used earlier.

While in Edit Mode, create your “disc.” It should be a flat, ten sided cylinder that's about 
one tenth of a unit thick and have a one unit diameter (although it ultimately doesn't 
matter – we'll scale it later). Next, add an elongated, eight sided cylinder right beside it. 
The disc should have its flat, broad side facing you, while the elongated cylinder should 
be running parallel to the X axis. This flat “disc” will be the palm of our hand, while the 
cylinder will be a finger joined to it.

Now we have a unique problem: we need weld an eight-sided polygonal face from the 
end of our cylinder onto a four-sided square face on the edge of our disc. To do that, we'll 
need to pinch two adjoining vertexes together around the circumference of our cylinder, 
so we'll have eight edges on one side, four on the other.
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First, select two adjacent vertexes on an edge. Next, scale the two vertexes using S key to 
scale them towards each other. We don't want to grab the vertexes and move them toward 
each other – otherwise we're likely to go chasing our vertex all over the X, Y and Z 
planes. Scaling the two vertexes together moves them appropriately across all of our axis.

Once the vertexes are overlapping, use our handy “Rem Doubles” tool in our editing 
buttons (F9). This should eliminate one edge and merge our two vertexes into one. 
Perform this same operation to join all adjacent vertexes together, until we just have four 
edges to one side of our cylinder.

Once you've squared the adjoining edge of your finger, get rid of the four faces at the end 
of the finger and the single face at the end of the palm where the two will meet. This will 
give you a single digit to reuse for each of your five fingers. Use Shift-D to duplicate the 
finger four times, and place them around the palm.

Now we need to create empty spaces on the palm to join our fingers to. Find five strategic 
faces on the edge of your palm, then delete those five faces. Scale the remaining four 
vertexes down to an approximate square, about the size of the open end of your finger 
meshes. With each of your five fingers, join the two open ends together and delete their 
duplicate vertexes to make them part of a single mesh.

HowTo Build with Crystal Space and Blender - Building a Character Mesh in Blender

Illustration 17: Creating primitives for our hand

Illustration 18: Pinching 8 edges into 4 by scaling two vertexes removing duplicates



Once we have all of our cylinders joined together, load up your reference image and 
match proportions of your mesh to the image. You'll need to do some scaling and 
tweaking, but eventually you'll have something that resembles a hand ready to go. Don't 
forget to look at your model from top and from the side – that way you can ensure all 
your fingers are in line with each other.

Now we can join our hand to the wrist we created on our earlier mesh. Highlight all your 
hand vertexes in edit mode, then switch into object mode. Select both the layer that our 
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body mesh exists on and the Blender layer that our hand exists on. Switch back into edit 
mode17. Scale and rotate the hand mesh appropriately so it looks in proportion to the fully 
body reference image we use. You hand is probably still rather flat, so inflate it a bit so it 
meets the proportion of the wrist and our reference image.

Once you have fleshed out your hand, delete a couple of faces where the hand will meet 
the wrist. We will join these open vertexes to our arm after preparing our main mesh. 
Move the vertexes surrounding your deleted faces so that they overlap the vertexes of our 
wrist. You may need to do some subdivisions between vertexes so they line up – 
remember, our wrist has eight vertexes, but the opening in your hand mesh may only have 
for our six vertexes.

The same warning I made earlier concerning how to overlap two sets of vertexes still 
applies – stick to front, side or top views only. Trying to get vertexes to meet in freelook 
mode is, at best, frustrating. It may look like your vertexes are right on top of each other, 
but the moment you switch back to looking down the X, Y or Z axis you may notice that 
you are completely off.

Once you are happy with the wrist, switch to object mode. Select your main body mesh, 
then jump back into edit mode. Delete the faces at the end of your wrist, so the arm has a 
circle of eight empty vertexes at the end. You should now have two open meshes – one 
on the arm perfectly matched with the hand, one on the hand perfectly matched with the 
wrist.

Jump back into object mode, then Shift-Click on both hand and body meshes. Join them 

17 Make sure you do all your rotations/scaling/moving in edit mode, otherwise we have to go back and re-
orient our mesh later. Transformations done in object mode are done relative to the original origin of the 
object, but done relative to coordinate space in edit mode.
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together as one using Ctrl-J. Switch back into edit mode, and highlight the overlapping 
vertexes of your wrist and your hand. Merge them together by performing a remove 
doubles, just as you have when joining two meshes at their vertexes previously.

Building Feet
We're just going to create easy “sock” feet for our mesh – we aren't going to go into any 
great detail for the toes. Since we're assuming most of our characters are going to have 
shoes (or even toes) that largely act as one unit, we'll let our texture mapping take care of 
any digit detail.

Our foot is going to be a simple 12-sided cylinder. Move to a new layer in Blender, load 
up our foot reference image, then plop a new cylinder with twelve sides onto our scene in 
edit mode. Move vertexes to look in proportion to our reference image, then join it to our 
main body mesh the same way we joined the hand.
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Creating the Head
Creating the head can be the most tedious and time-consuming. Facial features are often 
the most distinguishing characteristic in human meshes and have to be built with care. 
Faces are also really “bumpy” and seemingly disproportionate, so building a low-vertex 
model that can follow the curvatures of a face is tough. Noses can be especially tough.

First, let's start with a cube. Select all the vertexes, then hit W key→Subdivide 
Smooth→25% to do a 25% smooth subdivision on our cube. This will divide each line on 
our cube in half, and then smooth out the edges. Load up your front-facing head reference 
image, and scale your new mesh to be approximately the same size.

The front of our face is going to need additional detail. Select the nine front-facing 
vertexes of our face, then do yet another subdivision on them.
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We're dealing with a bigger grid of vertexes now, and we need to make sure we're not 
creating any sharp angles along the faces of our mesh. So far we've managed to keep 
things smooth with our subdivisions, but we'll need to do the same when we're moving 
vertexes around.

Use the O key to jump into proportional editing mode. This will move adjoining vertexes 
along with the vertex we're grabbing – much like points a rubber sheet will move when an 
adjacent point is moved. A smooth falloff works well for some work with the 
proportional editing tool, but you may need a sharp falloff  for more pronounced features 
such as noses or eyebrows. Experiment and see which one works best for you.

First, let's create a nose. Switch to a side view, and then load our head profile reference 
image. Using the sharp falloff setting for the proportional editing tool, grab the center 
most vertex and move it in proportion to the nose of your background image.

Your nose needs a more defined origin. Switch back to a front view in Blender's 3D 
Window, then grab the two vertexes on either side of the “nose” vertex. While still using 
the proportional editing tool, scale the two vertexes along the X axis towards the center 
nose. This will “pinch” the side of our nose together.
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Continue doing similar operations for the remainder of the face. Whenever possible, do 
not grab vertexes – instead grab the corresponding vertex on the other side of your mesh 
and scale them together. This will keep all of your vertexes more uniform and smooth. 
For example, when creating a chin it is much easier to grab the bottom three vertexes, use 
the proportional editing tool and scale/move the vertexes together to create more 
symmetrical features.

Keep using proportional editing, scale whenever possible and tweak your vertexes to 
match your front and side reference images as much as possible.
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To join the mesh to our body we'll use the same method as with the hand and the foot. 
There's one catch of course: we've only done one side of our body... but we have both 
sides of our head. Let's chop off the right half of the head, then join the two meshes 
together. Since we did a subdivision on a cube, we should be able to neatly halve our 
head mesh before joining it to our body object.

You may also notice that we don't have a neck... you can subdivide a few vertexes above 
the shoulders and at the bottom of the head to create two or three contact points, then fuse 
those vertexes together. That should give us something to work with in order to create a 
small “neck.”

Finishing The Mesh
Lessee... neck, hands, feet, arms, legs, body...  check. Now we have a complete half of 
our human mesh. We just need to create the other half!

Our human mesh is meant to be symmetric, so we only created one half of the body up to 
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this point. If we did both halves at the same time, we could have very easily made a tweak 
on one side that wasn't exactly mirrored on the other side. This can lead to big headaches, 
especially with texture mapping and animation.

Before you continue, be sure you're happy with your mesh up to this point. Double-check 
with your reference image. Does everything look proportional? Do you follow the same 
sizes and ratios as your reference image? Does anything look out of place? If so, now is 
the time to fix it.

In fact, you might want to keep this mesh in a separate file and back it up elsewhere at 
this point. Making mesh changes to one half of the body is much easier than trying to 
alter both sides in the exact same way.

Now let's make this guy whole again. Select all of your vertexes in edit mode, hit Shift-D 
to duplicate them and then drag your duped vertexes off to the side. Hit M key to mirror 
your newly duplicated vertexes, and mirror them along the global X axis. Move your new 
half so that the two have overlapping vertexes exactly at the median of our mesh – this 
should give us two sets of overlapping vertexes. One set will correspond to the left half's 
open side, the other half will correspond to the right half's open side. Once the open sides 
overlap, select the vertexes in the middle and do a “remove doubles” to join them 
together. Experiment with the limit on the remove doubles button to ensure you join all 
your vertexes but don't remove adjoining vertexes; for me an acceptable value was 0.025.

Now that you've joined your meshes together, you can double-check to ensure everything 
looks correct. In my instance, my hips were way to bootylicious and the neck wasn't quite 
thick enough. Luckily, this can easily be fixed by scaling both sides of vertexes 
symmetrically.

As an example, let's work on the neck. In the middle of my neck I had two vertexes I 
chose not to join with my “remove doubles” command – I de-selected them from all the 
other vertexes that ran along the median of my mesh. After I joined the two sides of my 
mesh together, I grabbed these two vertexes and scaled them along the X axis (the S key 

HowTo Build with Crystal Space and Blender - Building a Character Mesh in Blender

Illustration 28: Duplicating the left side to make a whole mesh



followed by the X key Scales the vertexes along the X axis). This allowed me to widen 
them out a bit and create a broader neck.

Same sort of technique applies to my mesh's overly broad hips; I simply selected the 
midsection, then scaled it along all axis.

Tweak your mesh until you're happy with the results. You should now have something 
roughly human-like weighing in around only 800-850 polygons. Nice!

During our mesh operations, it is very likely that some of our faces' normals were flipped 
and are now facing inward. This will cause our mesh to render very strangely; all mesh 
faces are one-sided, so we need to make sure the appropriate side is showing. If they don't 
face the right direction, we won't be able to see our mesh.

Switch to solid shading using the Z key. Click the “Draw Normals” button in the Editing 
buttons window (F9). The cyan lines will be pointing in the direction of the normals – all 
of your lines should be facing outwards. Chances are they're not, and instead your left 
with an inconsistent mix of inward and outward facing polygons.

Luckily this is an easy fix. Hit Ctrl-A to select all of your vertexes in edit mode, then hit 
Ctrl-N and select “Recalculate normals outside” to make all of the faces point outward. 
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Double-check your mesh and ensure all of your normals are in fact pointing outside.

To finish up, we just need to make sure all of our transformations are applied. In object 
mode, hit Ctrl-A, Alt-G, Alt-R and Alt-S to apply and clear your object's location, rotation 
and scale. This will ensure our object is located at its origin and later exported correctly.
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Homework Assignment #6

1. Read the “Unwrapping Suzanne18” tutorial in the Blender Documentation Volume 
I – User Guide.

18 http://www.blender.org/modules/documentation/htmlI/x5336.html
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Texture Mapping Character Meshes

Texture mapping allows you to cover your mesh with a image you assign on a vertex-by-
vertex basis. Blender makes this easier by creating “seams,” a grouping of one or more 
faces. By assigning an organized number of faces to a seam, we can easily organize the 
surface of our mesh for UV19 texture mapping.

Building a Test UV Map
First we need to build a test texture map that allows us to test our mapping coordinates 
and ensure nothing gets out-of-scale. The easiest way to do this is to create a 
checkerboard pattern thats is 512x512 pixels. Since this will be a grid of many small 
squares, we can check our mapping on the fly and make sure we don't stretch our scale 
our texture incorrectly on our seams.

Creating a test texture in GIMP is easy. Just create a new 512x512 image, then select a 
new background/foreground color that is contrasting but easy on the eye. Pick something 
that doesn't shout – more mellow tones are much better; after a while your eyes can strain 
at striking colors. Select Filter→Render→Pattern→Checkerboard... from your image, 
then an offset of 0. This will give you a grid, that alternates your foreground and 
background colors.

19 The “UV” in “UV Texture Mapping” is for the names we give the two axis on our texture map, the U 
axis and the V axis. Since we're talking about a two-dimensional surface we could refer to the axis as X 
and Y, but we're already using these names in three-dimensional viewports. So X, Y and Z are reserved 
for the 3D perspective, U and V for the 2D perspective.
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Building Seams
First, jump into face select mode for your mesh. Are some of your faces see-through? 
You didn't switch your normals earlier – go back to “Finishing the Mesh” in the above 
section and make sure all your normals are facing outward.

Once your faces are ready, we need to start grouping together faces for texturing. In 
Blender you can group together faces by using “seams,” reference lines that don't have 
any particular meaning to the mesh itself but help the artist divide up the surface of the 
object.

In the “UV/Image Editor” window, go to Image→Open and open the UV test texture you 
just created. In your 3D editor window, switch to face select mode and change the 
viewport shading (or draw type) to “textured.” Select all the faces of your mesh, then hit 
the U key to bring up the UV mapping window. Select “Standard 1/1.” Now move your 
cursor over to the UV image window and hit A again to select all the vertexes in the 
image window. Hit the S key to scale all the vertexes selected, then shrink your square 
down to about the same size as one of the squares in your grid. Grab it (G key) until it 
overlaps one solid square color located on your grid. This should give you a single, 
consistent color across the whole mesh; it will be our “panic color.” Should we ever 
accidentally forget to map a face to our UV image, this ensures some (albeit ugly) 
mapping will still exist. We should also more readily notice when a face doesn't have an 
assigned section on the UV image.

Now it's time to divide up our vertexes & faces. Switch into edit mode in order to start 
back with vertex manipulation. It should be a fairly straightforward operation – we select 
each vertex around our faces, so in the end we've outlined a “ring” of vertexes that will 
surround the mesh that compromises the face, including the neck.

After you select this ring of vertexes, hit Ctrl-E to create a seam. You can test it out by 
jumping back into face select mode, picking one 3D face, then hitting the L key to select 
all faces bound by this seam. Assuming all went well, you should see all the faces within 
the seam selected at once.
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Continue creating seams around the body in much the same way for the back of the head, 
front of arms, back of arms, hands, torso, front of legs, back of legs, top of the feet and 
bottom of the feet. Don't be surprised if you have nearly a dozen or so seams separating 
your mesh into distinct regions. The way I usually distinguish what parts of the mesh are 
grouped by a seam is by visualizing what type of texture they might have. The face will 
have very detailed textures, so it will be its own seam. The back of the head may be more 
or less uniform, so it gets its own seam. Things that are still cylindrical, such as arms, 
legs and the torso can be tricky; you may need to divide them into half and texture them 
likewise. Blender doesn't quite understand us when we attempt to “wrap” a seam around 
in a sort of deformed cylinder, so it's best to divide the top half and bottom half of the arm 
into to planes for ease in grouping. Same with legs and the torso – it's somewhat easier to 
divide them into front and back halves by grouping the front or backward facing faces 
likewise with seams.

There are a couple of good rules of thumb you should follow when creating seams. First, 
make sure you don't select three adjacent vertexes together... this will case faces to be 
selected and confuse Blender as to what you actually want to loop together. For example, 
let's look at the back of the head. It's very easy to select a midline vertex at the base of the 
occipital region of the skull, one close to the clavicle and then another adjacent vertex 
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close to the temporal region. This selects a face that lies in a region of the neck, and 
makes Blender think that this polygon is what needs to be encapsulated in a seam.

To make things more plain to Blender, we need to de-select one of the vertexes. You may 
need to make some trial-and-error as to which of the three vertexes Blender can do 
without, but you should be able to remove one and still define a more sensible seam. In 
our example on the back of the head, we would remove the temporal vertex so that the 
occipital and clavicle vertexes would define the seam.

The second rule is that seams are reflexive – that is you can select everything inside a 
seam or everything outside a seam. It all depends on which face you select first – if you 
select a face inside your seam and hit L, you select all face inside the seam's bounds. If 
you select a face outside the seam, everything outside will be selected. This means you 
could define seams for everything but the back of your torso, hands and tops of the feet.
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Once you have all your seams defined, you should have a series of grouped faces to 
texture. Now for the difficult part – mapping them to our UV texture in correct 
proportion. We'll use the checkerboard pattern of our test texture to ensure that we are 
maintaining a consistent scale between seams and that we aren't “warping” our texture by 
making some areas bulge while other areas squish the texture together.

Once again, just to beat this point into the ground, make sure your object has all local 
coordinates by using Ctrl-A, Alt-G, Alt-R and Alt-S to apply all transformations and clear 
any transformations/rotations/scaling on your mesh. We don't want to be doing 
transformations relative to some object origin that doesn't sync with our mesh origin.

HowTo Build with Crystal Space and Blender - Texture Mapping Character Meshes

Illustration 38: Our mesh in face select mode, divided up into seams



Texture Mapping
We will do our mapping work while in “UV Face Select” mode in Blender with our 
viewport shading sent to “textured” (Alt-Z key). First, let's select the faces on the front of 
the torso. Our seam should have defined all the faces we want, so we should just be able 
to jump into face select mode in Blender, select a single face on the front of the torso, 
then hit the L key to select the rest. Next, hit the U key and select “LSCM” to map our 
selected faces to our test texture.

The same least square conformal map method (LSCM) algorithm preserves angles and 
skews very well but does not preserve the scale; the resulting texture map will fill up our 
test texture window and probably be rotated the wrong way. Use the R key in the 
“UV/Image Editor” window to rotate the selected vertex until they appear oriented 
upright, in the same alignment as on the mesh. Next, scale your UV selection using the S 
key in the UV editor so the selection only takes up about 1/8th of the test image. Your end 
result should have a checkerboard pattern mapped onto your mesh's chest in a horizontal 
and even pattern.

To the back half of the torso in the same way, and transform the resulting UV map next to 
the front half of your torso on our test image.

Continue to use the LSCM method for the arms. Once you create the UV mapping for one 
half of one arm, you should uniformly scale the remaining UV vertexes to be the same 
size and dimension. Do the same for the legs as well. And while you're at it, find a scratch 
piece of paper and write down which group of faces (top of left arm, back of right leg, 
etc.) is at what part of your test image.
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You can also use this method for the tops of the feet – but the bottoms of the feet we'll 
save for a later technique. Use LSCM for the tops of each foot, then scale it to match with 
the size of the leg's checkerboard pattern.

Hands are a little different. For our purposes we are just going to map our hands with a 
uniform skin texture, so we don't need to worry terribly about getting the proportions 
correct for each little finger. Switch into overhead view (7 key), select the faces for one 
hand, then select “From Window” from the UV mapping menu (U key). Scale it until it 
looks correct in proportion to the arm's test texture, then transform it in the UV editor 
window and place it next to some other UV vertexes you've been mapping out. Perform 
the same mapping for the other hand, and scale it until it's the same size as the first hand 
you mapped.

Use the same method for the bottoms of our feet. Rotate your viewport until you're 
looking directly at the bottom of your mesh, then select the faces at the bottom of one 
foot. Use the “From Window” algorithm for UV mapping, then scale accordingly. 
Repeate for the other foot.

Let's try the face next. The head seams are a bit more difficult since they are already 
rather angular and deformed. As a result, LSCM can't take us all the way. We'll first need 
to do the best approximation that we can then neaten up our UV mapping afterward.

First, let's select all the faces inside the seam for the front of our head. Once our faces 
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have been selected, ensure we're looking at a 100% front view of our mesh by hitting the 
1 key. From here, hit the U key to select our UV mapping and choose “From Window.” 
This should give you a UV mapping that pretty much resembles what you see in your 
viewport... which is great if you're just looking directly at the front of your mesh. But 
rotate to either side and you'll notice our UV map is seriously stretched out.

To fix this, we first need to “pin” the UV vertexes that look correct so they can't change. 
By using the UV editor's pin feature, we can alter the rest of our UV mappings without 
altering the ones we like.

In the UV editor, use the border select tool to select the vertexes in the center of the face 
that look correct. If you notice, mostly the cheeks and temporal regions are out of whack, 
so we'll largely select the inside area and affix it to our UV mapping. Once you select the 
appropriate vertexes, hit the P key in the UV editor to “pin” them to our map.
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Now that we've made sure the faces that are correct won't move, let's fix the remainder. In 
the UV editor window, hit the E key and select good ol' LSCM. The LSCM algorithm 
should now take the angles of our faces into account and scale our UV mapping 
accordingly. The faces that were improperly mapped should be expanded into place, and 
all is right with the world.

You can now unpin your vertexes by mass-selecting them all using the border select tool, 
then using Alt-P to unpin all of your vertexes and return them back to normal. Zoom out a 
bit and now take a look at how the checkerboard pattern on your head looks in 
comparison to the checkerboard pattern on your torso. Chances are pretty good that the 
squares on the head aren't the same size or scale as the the squares on the torso. Select the 
vertexes in the UV window that correspond to your head, and use the S key to scale them 
appropriately. When you're done, the squares on the head should be approximately the 
same size as the squares on your torso.
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Perform a similar mapping for the back of the head. You may need to tweak a few 
individual vertexes, but the process should remain the same.

You should now be done mapping the test texture to your mesh! Rotate your model 
around a bit and double-check all your UV mapping. Ensure the checkerboard pattern is 
uniform and consistent throughout. If not, tweak vertexes as necessary. You should also 
notice that the little UV mapped square that we created at the beginning of this chapter 
has now disappeared – we've should have since re-mapped all of the vertexes that were 
once part of that global pool of UV vertexes. Once you're happy with the results, save a 
backup of your Blender file if you haven't yet done so.

Creating UV Textures
Now we'll work on replacing the test texture we've been using with a “real” texture that 
looks vaguely interesting. Before we paint textures onto an image, we need to build a 
template image that we can fill in. This template should allow us to see the bounds and 
sizes of our UV map, so when we import it back into Blender our current definitions 
match up exactly.

First organize your UV vertexes so that they fit into more of a “square” arrangement. This 
should shove your mapping into the lower-left corner and have minimal dead space; all of 
our mappings should be crunched into the smallest square surface area possible.
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If Blender and Python is installed correctly, you should be able to move your mouse over 
to the UV/Image Editor and click on UVs→Save UV Face Layout. Once the dialog for 
this plugin comes up, we need to select “All Faces,” “Wrap,” “Wire Size: 1” and change 
the “Size” parameter to be 512 – equal to the size of our test UV texture. Deselect “Ob” 
so that the object name does not become the file name, and type in the full path for the 
exported image including the filename, such as /home/user/uvmap. Once you're ready, hit 
“EXPORT.”

Open the resulting image up in GIMP. Note that each face is distinctly drawn in our UV 
map... something that we don't necessarily need. Using the select contiguous regions tool 
(Z key) with a threshold value of 0, select the whitespace surrounding your mesh. 
Reverse your selection using Select→Invert (Ctrl-I), then grow your selection by one 
pixel using Select→Grow... - this will give some margin of error on our texture. Use the 
bucket tool (Shift-B) with the “Fill whole selection” option to fill your UV maps with 
something nice and loud, like magenta. Using a fairly obvious color will let us know 
when a texture hasn't been properly UV mapped.
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Next we need to create a skin pattern, as described in the earlier section Building 
Textures for GIMP. You can use a digital photo of your arm if you wish – just select an 
area that's fairly uniform in tone and texture.

Next you can start filling in arms, hands and head with the skin texture. This will provide 
a base to start working with on a more detailed level.

Create other patterns for clothing, hair, etc. and apply them to the UV map. keep going 
until all the magenta is completely eclipsed.

Once you have completed your pattern fills, start adding details such as eyes, teeth, more 
hair, whatever. This is your chance to be as (un)artistic as you wish.
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Once you're either satisfied or repulsed by your final work product, save it. Jump back 
into Blender and open this newly revised image in the UV/Image Editor, then open the 
new image using Image→Open with the “Relative Paths” button selected. If all remained 
right with the world, this should overlap all of your current UV mappings and you should 
see a newly textured character model, ready for action.
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Homework Assignment #7

1. Complete Your First Animation in 30 Minutes20 in the Introduction to Blender21 
documentation

20 http://download.blender.org/documentation/html/c798.html
21 http://download.blender.org/documentation/html/p32.html
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Skeletal Animation and Character Rigging
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Homework Assignment #8

1. Setup your development environment for:

• KDevelop in KDE  

• Microsoft Visual C++ 6  

• Microsoft Visual C++ 7  

• Or just in general  

2. Complete tutorials 5.1-5.4 within Crystal Space's documentation to figure out how to 
build your first application, load a sprite and load a map.

3. Read section 5.8.1 in the Crystal Space manual about smart pointers

4. Spend some time spiffing up your map and character model. We'll be using them on an 
ongoing basis in our tutorial, so create something big to walk around in and a creature 
of your own creation.
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Creating a Stand-Alone Application

So far we've used walktest and viewmesh to load the entities we've created. Now we need 
to develop our own application that will load our map and place the character model 
inside.

The design of our application should be object-oriented whenever possible. For ease of 
understanding, however, we're going to start by adding code then object-izing it later. 
Maps, characters and entities should exist as structures containing meshes, properties and 
methods that govern them. No details about maps or characters should be stored in the 
code itself. Spawn points, animations and entities should be defined by external resource 
files.
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Appendix A: Using CrystalSpace with KDevelop 3.2

KDevelop 3.2 is a very nice development environment written for KDE, an X11 desktop 
environment. Several very useful features can save you a good deal of time and headache, 
including Valgrind integration, Subversion integration, custom development profiles, 
source auto-completion, automatic generation of build files... the list goes on.

The current version of CrystalSpace documentation is a little sparse when it comes to 
KDevelop integration, and it covers an older version that doesn't exactly translate over. 
Plus, adding CEL on top of the build environment can make things a little trickier.

Building Debug and Optimized Installations of CrystalSpace
To get a good development environment working, we'll first need to build CrystalSpace 
and CEL using the appropriate configuration flags. We'll want two different types of 
builds: one with extra debugging info enabled, the other optimized for speed.

First, download the versions of CrystalSpace and CEL that you'll want to be working 
with, as outlined in their respective sections of this document. Make sure that your build 
goes successfully and that you can run walktest and celtst for CrystalSpace and CEL. 
Don't install the packages just yet – just build and test them. I'm assuming you're doing 
this in a directory such as $HOME/CrystalSpace.

Next we'll need to configure two types of builds for each package: one for testing and one 
for “optimized” builds. The build process is the same for each, except we'll be passing 
some additional files to the configure script.

In both the CrystalSpace and CEL home directories, run the following command to 
configure your environment:
./configure -–enable-debug -–enable-extensive-memory-debugger –-
prefix=/opt/CrystalSpace/debug
This will build a version that enables additional debugging info, sets additional asserts to 
catch errors early, and doesn't do as many compile-time optimizations so code can be 
more easily backtraced. It also catches common memory errors – so you can hopefully 
diagnose the problems before they become something huge.

Create the directory /opt/CrystalSpace/debug, then build and install this configuration of 
CrystalSpace and CEL. 

Next, we'll need to build an optimized version of CrystalSpace and CEL. This will enable 
some compile time optimizations and remove debugging code so things execute as 
quickly as possible22. In both the CrystalSpace and CEL home directories, run the 
following command to configure your environment:

./configure –-prefix=/opt/CrystalSpace/optimized
Create the directory /opt/CrystalSpace/optimized, then build and install this configuration.

22 Sometimes a bug will manifest itself with an optimized build of CrystalSpace but work just fine with a 
debug build. This often happens due to problems with memory management or thread allocation – 
unfortunately they're often tedious to debug. There's not a whole lot you can do, aside from inserting a 
bunch of printf's to trace the code, then running a profiler to perhaps find the source.
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Setting Up a New Project in KDevelop
Next we'll need to start a new project in KDevelop. Open up KDevelop and start a new 
project using the C++ “Simple Hello world program.” Alter your license and source 
templates as need be, then finish your configuration and go to the main project window.

Here we'll need to set up our development environment. Go to Project→Project Options 
in the project window, Then click on “Configure Options.” The “Configuration:” drop-
down box should have “default” listed as the currently selected development 
configuration. From here, we'll add the following info:

General Tab:

Configure arguments:

Here I put architecture-specific arguments to target my specific machine. Since 
I'm running an Athlon XP, I just use the i686 targets such as:

--host=i686-linux --build=i686-linux –target=i686-linux
Linker flags:

Here we put the script that generates the CrystalSpace and CEL linker flags for us. 
Be sure and use the backtick mark ` since we're executing files and passing along 
their output, not quoting them.

`cs-config --libs` `cel-config –lflags`
Environment Variables:

Add environment variables, including the home directory variables for CEL and 
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CrystalSpace. We'll also need to add the path to cs-config and cel-config to our 
PATH environment variable. We're pointing to the place where we can 
build/rebuild CrystalSpace and CEL to our whim – not our static debugging or 
optimized installations.

CRYSTAL $HOME/CrystalSpace/CS23

CEL $HOME/CrystalSpace/cel

PATH $PATH:$CRYSTAL:$CEL

C Tab:

Compiler flags:

Again, automatically generated for us by our config scripts.

`cs-config --cflags` `cel-config --cflags`
C++ Tab:

Compiler flags:

Again, automatically generated for us by our config scripts.
`cs-config --cxxflags` `cel-config --cflags`

Once we hit “OK” KDevelop will ask if we want to re-run configure... say “Yes.” Now 
we have built a development environment off of our rough, rebuildable CrystalSpace 
installation. This will be the default one we can use – it can be tweaked, rebuilt and 
updated as necessary. So long as we don't perform another install, our optimized and 
debug versions stay intact.

Build one of the CEL tutorial apps (such as celtest) in our new development environment. 
You can just move over the source from cel/apps/celtest, copy over CEL's vfs.cfg so mesh 
data loads correctly, then try to compile and run it from scratch. Make sure everything 
runs smoothly.

Building a Optimized Configuration
We'll do the same thing over again, this time with the “optimized” configuration selected 
in the drop-down menu.

General Tab:

Configure arguments:

Architecture-specific arguments

Linker flags:
`cs-config --libs` `cel-config –lflags`

Environment Variables:

23 Don't forget that I'm assuming you did your initial build in $HOME/CrystalSpace. Depending on where 
you downloaded/built your CrystalSpace and CEL packages, this path may be different.
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CRYSTAL /opt/CrystalSpace/optimized/CS

CEL /opt/CrystalSpace/optimized/cel

PATH $PATH:$CRYSTAL/bin:$CEL/bin

C Tab:

Compiler flags:

`cs-config --cflags` `cel-config --cflags`
C++ Tab:

Compiler flags:

`cs-config --cxxflags` `cel-config --cflags`

Hit “OK” and re-run configure. Perform a Build→Clean Project, then rebuild and re-run 
our test application. Verify that things work as expected.

Building a Debugging Configuration
One more time, this time with the “debug” configuration selected in the drop-down menu.

General Tab:

Configure arguments:

Here we're going to ditch our architecture-specific tab and tell KDevelop's 
configure script to give us all the debugging info it has.

--enable-debug=full
Linker flags:

`cs-config --libs` `cel-config –lflags`
Environment Variables:

CRYSTAL /opt/CrystalSpace/debug/CS

CEL /opt/CrystalSpace/debug/cel

PATH $PATH:$CRYSTAL/bin:$CEL/bin

C Tab:

Compiler flags:
`cs-config --cflags` `cel-config --cflags`

C++ Tab:

Compiler flags:
`cs-config --cxxflags` `cel-config --cflags`

Hit “OK” and re-run configure. Perform a Build→Clean Project, then rebuild and re-run 
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our test application. Verify that things work as expected.

Final Notes
We now have a working build environment for our CrystalSpace apps. Switching 
between configurations will help us more easily debug our code, as well as test out new 
CrystalSpace releases before installing them.

It's a good idea to take advantage of KDevelop's native Subversion support – using some 
means of a source code management tool helps immensely. Even if you're just writing an 
app to learn CrystalSpace or just typing up a quick proof-of-concept application, being 
about to roll back to your last known good build or looking at the difference between a 
working and historical file can save tons of time.

HowTo Build with Crystal Space and Blender - Appendix A: Using CrystalSpace with KDevelop 3.2



Appendix B: Building a Standalone Python 2.3.5 & Blender 
2.3.7a Instance in Linux

Many distros have problems with packaging Blender, mainly because Blender evolves so 
quickly yet uses older versions of Python. The distribution of Linux I often use, SuSE, 
always has problems with Blender packages even though it installs it by default. While 
the main application can run, a huge chunk of functionality is disabled because its Python 
functionality doesn't work correctly.

The best way to fix this problem is to install your own version of Blender with a self-
contained version of Python. This allows Blender to have the Python version it wants to 
run while not interfering with your distro's chosen version.

Install Python 2.3
Next, download Python 2.3 from http://www.python.org. This you will need to build from 
source, and when configuring our build we will explicitly need to tell the configure script 
that we wish to install Python into Blender's installation directory. For example, if 
Blender will be installed in /opt/blender then building Python from the console may look 
something like this:

./configure --prefix=/opt/blender/python --enable-unicode=ucs424

make
make install

The ucs4 value to the unicode flag is sometimes necessary on some recent distributions – 
sometimes not. Watch your Blender console to see if you notice any problems. If you see 
unicode errors, try recompiling Python with this flag omitted.

First run the Python interpreter and make sure it works correctly. In the above installation, 
such a command would be:
/opt/blender/python/bin/python
You should bring up a Python dialog with no errors. Hit Ctrl-D to exit the interface.

Install Blender

Using the Binary Distribution

Grab the latest version of Blender from http://www.blender.org - here we will be using 
version 2.3.7a. Follow the installation directions for whatever package you downloaded. 
Once you've installed Blender, make special note of its installation directory 
(i.e. /opt/blender).

Now that we have a new version of Python built, we need to tell Blender where it is. 
Open up a console and set the PYTHONHOME environment variable to be where the 
“python” binary was installed. For example, using the example above we would set our 
environment variable using:

24 I have noticed problems with shared library loading on my 64 bit platform. In my case, I just compiled 
Python on a 32 bit machine and moved over the binaries manually.
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export PYTHONHOME=/opt/blender/python/bin

Building from Source

If you build Blender from its source, you may want to use the source included in your 
Linux distribution of its Blender version is relatively up to date. For example, with SuSE 
10 I install the Blender 2.37a source RPM and use the included source patches for GCC 
4.

For example, after installing the source RPM for Blender SuSE can unpack the sources, 
apply patches and prep the build environment by running:
rpmbuild -bp /usr/src/packages/SPECS/blender.spec

Once you unpack & patch your Blender source directory you need to tell Blender where 
to find Python. While GNU make is supported, at times the Makefiles can generate build 
errors. If you choose to try make, you can edit your Python paths in the file 
source/nan_definitions.mk. However the Blender build process seems to be more 
geared towards the SConstruct build tool, so you may want to customize your scons build 
instead. Find the SConstruct file in the root of your source directory, open it up and look 
for the section starting with “if sys.platform == 'linux2'.” Directly below this 
section you should see several python_ name/value pairs. Set them to mirror what you 
installed earlier with Python 2.3.5. For example:
# Python library information
python_lib = ['python2.3']
python_libpath = ['/opt/blender/python/lib/python2.3/config']
python_include = ['/opt/blender/python/include/python2.3']

Once you have your local paths set, use the command scons to build Blender. Ensure that 
you don't have a PYTHONHOME environment variable set – instead let your native 
Python install work with Sconstruct.

Once your build is completed, move the following files into your installation directory 
(such as /opt/blender):

bin/
blender
blenderplayer
release/
doc/

Testing Blender and Python Together

Attempt to launch Blender by manually typing in the full path to the executable. In this 
case, it would be:
/opt/blender/blender

Watch the console for errors. You should see something akin to “Using Python version 
2.3” as it launches. Once it does, verify that the Python plugins are properly installed by 
taking a look at the list of importers and exporters. You should see a list with several 

HowTo Build with Crystal Space and Blender - Appendix B: Building a Standalone Python 2.3.5 &
Blender 2.3.7a Instance in Linux



python-looking icons to the left – these are the Python scripts that run alongside Blender.

Test your installation by invoking one of the Python importers, such as the .obj or .raw 
importers. Your Blender installation should present you with a file dialog – if not, check 
your console and see what errors were returned by Python or by Blender.

Install 4Suite
Next we need to install the 4Suite XML libraries that blender2crystal uses. Grab the latest 
release (we'll use 1.0b2) and unpack it. To build the source, use the following directives 
in your console, swapping out /opt/blender for whatever your installation path is.

export LD_LIBRARY_PATH=/opt/blender/python/lib
export PYTHONHOME=/opt/blender/python
/opt/blender/python/bin/python setup.py config --prefix=/opt/blender/python
/opt/blender/python/bin/python setup.py build
/opt/blender/python/bin/python setup.py install

To test, open up a Python console like you did to test your initial Python installation. At 
the prompts, type the following:

>>> from Ft.Xml import Domlette
>>> from Ft.Xml.Xslt import Processor
>>> print Processor

This should return something akin to
module 'Ft.Xml.Xslt.Processor' from 
'/opt/blender/python/lib/python2.3/site-
packages/Ft/Xml/Xslt/Processor.pyc'

Install blender2crystal
Last but not least, install blender2crystal as explained at http://b2cs.delcorp.org/ . This is 
usually just a matter of dropping the provided scripts into Blender's scripts/ directory.

Once the scripts are installed, test them out by starting up Blender within a console and 
going to File→Export→Crystal Space... This should bring up an exporter window 
allowing you to select what types of objects should be exported. If you receive an error, 
check your console to see if any errors or explanations have been piped out.
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Appendix C: Exporting Character Models into Cal3d

In the last tutorial I authored we created CanMan – an animated character made from 
cylinders. This time we're going even simpler: BoxMan!

For this section, you will need to build and install the latest version of the Cal3d libraries 
from CVS. This tutorial will use the most recent version checked out at 10/25/2005. Also 
note that this tutorial uses Blender 2.3.5 and is now several versions behind, however 
the cal3d exporter has changed in subsequent versions to use a binary XML file format 
instead of the original file format we need for Crystal Space.

Creating the Mesh
First we need to insert a cube into Blender. Make sure it sits directly on the x and z axis 
so the center of the bottom face is at 0, 0. Select only the top four vertexes, then extrude 
the face to create another cube attached to the top. Do this once more so the mesh is 
constructed of three extruded cubes.

Once the box mesh is created, we need to create a set of armatures to define the mesh's 
skeleton. Center Blender's cursor at 0,0,0, go into object mode and click on 
Add→Armature to insert the first bone. Have it go about halfway up the mesh, then 
single-click to finish the first armature and start a second, connected one. Stretch this one 
up to the top, single-click to anchor it then right-click to finish our skeleton.
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Go to the editing window (F9) and click on “Draw Names.” This will show the default 
Blender names assigned to our bones – usually “bone.001” or the like. We want to 
rename them to “Head” and “Foot,” so in object mode select the armatures, switch to edit 
mode, then hit Ctrl-A to select all of the bones. As long as you're still in the editing 
window you should see a list of “Armature Bones.” Rename the selected bones listed 
there to “Foot” and “Head.”

Now we need to link the mesh and the skeleton together. Switch back into object mode. 
Right-click on the mesh, then Shift-right-click on the armature inside. This should turn 
the outer box mesh magenta and the inner armature light pink. Hit Ctrl-P to make the 
mesh the parent object of the armatures. Select “Use Armature” and “Create from Closest 
Bones” when prompted.
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When we selected the “Create from Closest Bones” item in the parent menu, we told 
Blender to guess what vertexes should belong to which bones. Let's see how smart 
Blender was.

Stay in the editing window, select your box mesh in object mode, then switch to edit 
mode. Make sure none of your vertexes are selected (they should all be magenta). Take a 
look at the “Link and Materials” section: you should see a menu called “Vertex Groups.” 
They probably have the same generic names your armature did at first, such as “Bone.
001.” Select the first one on the drop-down list, then click on “Select.” The vertexes 
assigned to this group are now selected and highlighted on your mesh. If Blender 
guesstimated correctly, there should be a vertex group for the top half of the mesh, and a 
second group for the bottom half of the mesh. If it goofed and only did portions of the 
vertexes, use box select (B key), select the vertexes and then hit “Assign” to assign the 
selection to a group. Every vertex in your mesh should be assigned to a group.

Once you're happy with the vertex group assignments, rename the vertex groups to match 
the bone names (i.e. “Head” and “Foot”). Bone names and group names must be the same 
to be exported correctly  25  .

25 If you can't tell, I underlined the two points I forget constantly. The emphasis is as much for my 
edification as it is for yours.
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Now that we have the vertex groups assigned, a skeletal structure in place and a mesh 
constructed we can work on exporting the model to Cal3d format.

Exporting the Model from Blender into Cal3d Format
Go to File→Export→Cal3D Exporter in the Blender file 
menu. Make sure that “Export for Soya26” is selected 
since we need to transform the coordinate system from 
Blender to Crystal Space. Set the “Export to:” value to be 
the directory you want the cal3d files to be dumped into. 
The “File prefix” value will be a name appended to the 
beginning of each file name, so set it to “boxman” for 
now. If we need to eventually scale the image down or up 
(we've made it to large/small in Blender) we can do so 
with the “Scale” bar.

Once all the variables are set, click “Export” and 
boxmanCube.cmf and boxman.csf should pop up in your “Export to” directory. If you get 

26 This script was originally written by Jiba for his Python 3D engine called “Soya 3D.” Take a look at 
http://home.gna.org/oomadness/en/
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an error, double check and make sure all your vertexes belong to a vertex group and the 
vertex group names are the same as the bone names. Also ensure no “.” characters exist in 
the bone or vertex names27.

Now we need to create a Crystal Space cal3d file to describe our model as a sprite. Create 
a new file called boxman.cfg with the following contents:
<meshfact name="boxman">
   <plugin>crystalspace.mesh.loader.factory.sprite.cal3d</plugin>
   <params>
        <scale value="0.25" />
        <mesh file="boxmanCube.cmf" name="body" material="skin" />
        <skeleton file="boxman.csf" />
    </params>
</meshfact>

We should now have something to test out! Launch the app viewmesh from your Crystal 
Space installation, click somewhere in the window and select “Load Mesh.” Open up 
your boxman.cal3d file. You should now see an untextured (probably black) box standing 
in the middle of the room that looks like your newly created mesh. If you notice errors 
being spewed out to the console when attempting to load the mesh, make sure your cal3d 
file has the correct filenames for each cal3d resource to load. There is also an occasional 
bug in the script where skeletal information isn't exported; if you see “Could not load 
cal3d skeleton file” errors then close the Cal3d export window and restart it.

27 To avoid glitches in the export process, it's a good idea to quit the script and restart it for each export.
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Animating the Model
Now we need to add a couple of actions to our model: a walking animation and an attack 
animation. Considering that our mesh is just a big box... most will likely look stupid. But 
that's what first models are for: looking stupid. We can get creative later28.

Let's do the walk action first. Make sure you're on the first frame of animation in Blender 
– this is indicated by the button at the top of the edit buttons that shows “< 1 >” by 
default, meaning it's on the first frame. Jump into pose mode and pose what would be the 
first frame of a “walk cycle.” All you really need to do is grab the foot armature and pull 
it back slightly. This will tilt the whole mesh backwards. Make sure all your bones are 
highlighted (you can use the A key to deselect all vertexes, then A to re-select them) and 
hit the I key. Select “LocRot.” when prompted; this will save our first frame of animation. 
Copy the current pose into the buffer by selecting Armature→Copy Current Pose (or use 
the copy pose button). We'll need it at the end of our animation cycle.

28 I remember reading a tutorial on creating Doom levels back in the day... it had a quote I'll never forget: 
“Your first level will always suck.” That's the point of “first levels” existing. You'll have this big, lofty 
goal that you'll try to make happen on your first go-'round but it will turn out looking like a two year old 
drew it with a crayon in his mouth. Yet if you follow it through to its bitter, ugly end then you get the 
“first level suck” mojo out of your system. If you don't see things through and keep scrapping your first 
levels (or applications or models or whatever) before you finish, you'll be stuck in a cycle of crapola. 
Realize your first vision, burn it to a CD, then start again.
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Jump to the 11th frame of animation. Here we'll do much of the same except we'll tip our 
mesh forwards. Select your bones and LocRot again.

Now go forward to the 20th frame. We'll make our last pose the same as the first pose so 
the animation is nice and smooth – select Armature→Paste Pose (or use the paste pose 
button) to paste the pose we copied to the buffer into the current frame. Select bones and 
LocRot once more.

Switch to the scene menu (F10) and take a look at the “Anim” group. We need to tell 
Blender what our first and last frame of animation is – the default is something like 250 
frames (way more than our 20 frame walk cycle). Change “Sta” to be 1 and “End” to be 
20 – this way Blender restarts the animation after 20 frames.

Let's preview our animation in Blender. Hit Ctrl-A and the animation cycle should start in 
your active mesh window. Hit Esc to stop the animation cycle.

Export your model again using the Cal3d script. This time you should have a 
boxmanAction.caf file sitting in your data directory. Add a corresponding entry in your 
boxman.cal3d file right after your “skeleton” tag to register your newfound action:
<animation file="boxmanAction.caf" name="Walk" />

Load your cal3d model into viewmesh once again. You'll see the same object as before, 
except this time we'll have an extra menu item to select from. Click on the viewmesh 
window to bring up the menu, then select Set Action Loop→Walk. This will launch our 
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new animation! You should see a box wobbling in the middle of the room.

Jump back into Blender and go to the Action Editor window. Rename “Action” to 
“Walk.” Jump into the IPO Curve Editor and rename “Action.Foot” to “Walk.Foot” and 
“Action.Head” to “Walk.Head” as well. Re-export to cal3d. Notice that your 
boxmanAction.caf isn't exported? Instead you get boxmanWalk.caf. By renaming the 
prefix to the actions in the Action and IPO Curve Editors we can separate out our model's 
animations.

Let's create a new attack animation. Go into the Action Editor and create a new action. 
Rename it “Attack.” Once its selected, create an attack animation just like we created a 
walk animation, except more... attack-like. My animation goes like this:

Frame 1 Mesh is centered and still

Frame 10 Head bone rotated slightly backwards

Frame 15 Head bone rotated all the way forward

Frame 20 Copy of Frame 1

Once your animation is done, jump into the IPO Curve Editor and make sure the curves 
are renamed to match your action (i.e. Attack.Foot and Attack.Head). Export your model 
to cal3d once again and use these lines for your two animation tags in the .cal3d file:
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<animation file="boxmanWalk.caf" name="Walk" />
<animation file="boxmanAttack.caf" name="Attack" />

Save the file and load the boxman.cal3d file up in viewmesh again. You should be able to 
switch between the “Walk” animation cycle and the “Attack” animation cycle.

Types of Actions in .cal3d Files
We need to delimit which actions in our cal3d file is for travelling, which is for attacking 
and which are for idle loops. Take a look at plugins/mesh/sprcal3d/persist/dwarf.cal3d  in 
your Crystal Space source directory – it gives examples for most of the attributes 
supported by Crystal Space's Cal3d plugin.

Let's change our actions to be marked as “travel” and “action” types. Our current file 
looks like:

<meshfact name="boxman">
   <plugin>crystalspace.mesh.loader.factory.sprite.cal3d</plugin>
   <params>
      <scale value="0.25" />
      <mesh file="boxmanCube.cmf" name="body" material="skin" />
      <skeleton file="boxman.csf" />

<animation file="boxmanWalk.caf" name="Walk" />
<animation file="boxmanAttack.caf" name="Attack" />

    </params>
</meshfact>

Let's add properties for our animations, such as:

<animation file="boxmanWalk.caf" type="travel" name="Walk" base_vel="2" 
min_vel="0" max_vel="3" />
<animation file="boxmanAttack.caf" type="action" name="Attack" 
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idle_pct="33" />

Reload the boxman.cal3d file into viewmesh. Notice that “Attack” is no longer in the 
“Set Action Loop” menu? It has been moved to “Overrides.” The attack animation 
shouldn't loop for a character like a walk animation would; walking is a repetitive motion 
that can be displayed by an animation loop. Attacking is a single action that would 
interrupt the current action – for example, the boxman walking towards an opponent and 
trying to headbutt them.

First fire up the walk animation in viewmesh, then go to Overrides→Attack. Notice how 
the walk animation breaks, switches to the attack animation and then switches right back? 
This is how it should work in our application logic as well.

Adding Textures to Character Models
To map a texture onto our mesh and make it look nice and pretty, we'll need to use 
Blender's UV texture editing.

First we need to generate a UV template. To do this, open up the UV Editor in Blender. 
Select our box mesh, then go into UV face select mode. Use the A key to select all the 
faces in the model, then hit the U key to perform the UV mapping. Select “Cylinder” 
from the pop-up menu.

We'll now have a really long mesh in the UV Editor window. It's rather uneven as well. In 
the UV editor, use box and vertex select to move around individual vertexes and even out 
the UV mapping. You should end up with a uniform grid for your model's UV map.
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Start up Gimp and use it's File→Aquire→Screen Shot function to take a screen shot of 
our UV window. Using the “Select Contiguous Regions” tool (Z key) remove the dark 
portions of the image. Crop the image down so you only see the UV map. The result 
should be a black, flat, wireframe representation of our mesh. 

Once we have our UV template, we can start painting a texture on top of it. It can be 
anything you want – a face, another Gimp pattern, colors for each face, etc.

I opted for... erhm... surrealism. Save your image as a JPG in the same directory as 
your .blend file.
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Open the image you created in Gimp over top of the UV template by opening up the 
UV/Image Editor and clicking on Image→Open29. Once your image loads, you may need 
to scale the UV map so it fits over your new image. Make sure all the edges and corners 
match up, then view the textured result by switching a view window to a textured display 
mode. You may need to move the vertexes around even further to get the image you had 
in mind square on the mesh.

29 Don't forget to use the “Relative Paths” button!
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Now let's export again. This time our “Image prefix” value nees to be “this/” instead of 
“textures/” in the Cal3d export window. Make sure the image is in the same directory as 
your cal3d files.

Next we're going to add an entry for our image in the boxman.cal3d file. In the mesh tag, 
let's change the material attribute be the Crystal Space VFS30 path to our image. In this 
case, the tag would look like:
<mesh file="boxmanCube.cmf" name="body" material="/this/uvtemplate.jpg"/>

Load up boxman.cal3d one more time in viewmesh. Animate away... we've created our 
first Cal3d sprite for Crystal Space!

30 See the Crystal Space documentation about VFS paths. Right now we're using the VFS path /this/, which 
Crystal Space interprets as the current working directory.
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Appendix D: Map Building with GtkRadiant

Before proceeding, complete the introductory tutorial within GtkRadiant's documentation.

Creating a New Map
Now let's build our map. Create a directory named “data” within the base project 
directory you just created. This should be the same directory your executables will be 
created. For me, it's the directory cstutorial/, so I'll create a separate directory 
cstutorial/data. This is where we'll be placing all of our non-code items.

During your installation of GtkRadiant it should have installed a quake3 directory 
alongside it. This gives us some basic Quake III Arena textures we can use to experiment 
with, but we want to import our own textures straight from Crystal Space. For no 
particular reason, let's take the mystone2.gif from crystal/data/standard.zip and put it in 
the data/ directory we just created.

Problem with GtkRadiant is that we absolutely have to have our texture files stored in 
RGB TGA format. That's where our friend the GIMP comes in handy; fire up GIMP and 
open the mystone2.gif file in our data directory. Right-click on the file, then go to 
“Image→Mode.” Click on “RGB,” this will convert the file to a red/green/blue image 
format. 

Next right-click again and go to “File->Save As” to save our new file. In the drop-down 
menu for file extensions, select “TGA” and save the file. We should now have a new 
image called “mystone2.tga.” 
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Now we need to place the .tga file within a Quake .pk3 file. This isn't nearly as hard as it 
sounds – a .pk3 file is just a Zip file with a specific directory structure within it. Within 
your data/ direcory create a subdirectory named textures/crystal. Move your mystone2.tga 
file into the textures/crystal31 directory. Zip the entire textures direcory into a file called 
“mytextures.zip.” Rename it “mytextures.pk3.” If you open it up now in WinZip or Gzip, 
you should see the following contents:

textures/crystal/mystone2.tga

Place the mytextures.pk3 file into the quake3/baseq3 folder that GtkRadiant created 
during installation. Once you launch GtkRadiant (close it down and re-launch if it's 
already open), it should automatically notice our new texture pack and load it into the 
textures list.

31 Bear in mind I'm a Linux guy, so all my directories have front slashes ('/'). If you come from the 
Windows side of things (aren't you glad I wasn't a jerk and called it “M$ Windoze”) then substitute my 
front slashes for backslashes ('\').
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Now that we have our Crystal Space texture loaded, we need to create a room. Just as you 
did in the Radiant tutorial (remember that?), we'll start by just creating a basic box. First, 
select Textures->crystal and click on the mystone2 texture that pops up. It needs to have a 
red box around it.

Now let's create a new room by just drawing a box around the camera in our introductory 
z-axis view:
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If you go to the y-axis view, you'll notice our box is a little flat. Expand it out so we're in 
an actual box the camera can fit in.
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Once you strech out the box, hollow it out using the “Hollow” tool. If we had the 
mystone2 texture selected ahead of time, the walls should automatically have that texture.

We'll need to specify a place for our camera to spawn. Right-click somewhere within 
your box and select “info->info_player_start” to insert a spawnpoint. Move the box 
representing the spawnpoint onto the ground and a reasonable place on the map. Switch 
between x, y and z-axis views until you get things in the right place32.

32 Don't place your spawnpoint exactly on the floor – put him a little bit above. Otherwise your camera will 
get glued to the floor.
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Almost done. Now we have to insert a light – otherwise we're not going to see jack squat. 
Open up the entities menu by right-clicking in the box we created and select “light.” Take 
the default values, then place the light somewhere reasonable within the level... just as 
you did for the spawnpoint.

Save your work in your project's data folder as “arena.” This should create a file called 
“arena.map” in your data directory. 
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Converting Your Map to Crystal Space Format
Now that we have our map done, let's convert it to Crystal Space's XML format. To do 
that we will use map2cs, a command-line utility that comes with Crystal Space.

We need to setup certain definitions for the conversion process to refer to. The utility 
map2cs can take in a custom configuration file, so let's create one in data/ called 
map2cs.cfg. It should contain the following:

Map2CS.TextureSettings.pk1 = <path to quake3>/baseq3/mytextures.pk3

Map2CS.General.Scaling = 0.025

Map2CS.General.UseBSP = 1

Map2CS.General.RemoveHidden = 0

Map2CS.General.LightScale=30

System.ApplicationID = Map2CS

Make sure you replace <path to quake3> with the actual path to the quake3/ directory that 
GtkRadiant created for you upon installation. Now let's call map2cs and convert our map 
to a Crystal Space .zip file:
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> map2cs arena.map arena.zip map2cs.cfg33

This will translate our Quake map file and textures to Crystal Space format, then organize 
them all within a .zip file. To check and make sure our map converted correctly, load it 
within the walktest application. This will load our map and place us right were our spawn 
point was. Make sure you're in the same directory as arena.zip, then invoke it with:

> walktest arena -relight

Move the camera around a bit. If you can't get the camera to move, make sure your player 
start position is not touching any walls or the floor. If you need to do any fine-tuning, do 
so now and re-convert.

33 If you get a “command not found” error, make sure the directory that contains map2cs, walktest, etc. 
(usually the bin/ directory within your Crystal Space installation) is in your path.
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