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Intro
The first version of this tutorial used a number of tools - GtkRadiant, Blender, Gimp, 
blender2cal3d and map2cs. This revision shifts things around to match how Crystal Core 
development is proceeding, using a more streamlined toolset. Blender is used for both 
model and map building now with Gimp is still used for textures design.

The toughest part of a massive project like creating an interactive space is finding all the 
tools to get started. As we proceed through the tutorial all data, entities and code will be 
created from scratch (well... as much as possible...). The idea is to give you, the 
formidable Crystal Space powerhouse you are, an idea of the resources needed to 
complete a project. Getting a working toolchain running is always half the battle - 
hopefully this doc will cut some of that initial setup time down.

This document is separated out into two sections: creating artwork for Crystal Space and 
coding a standalone Crystal Space application. In the first section we won't even open an 
IDE – we will use our toolkit to create levels, character models and sound then test it 
using the default Crystal Space utilities. The second section will load and manage these 
entities within an independent application.

Our Formidable Goal

Every project needs an end goal in mind. A moment where you can finally throw up your 
arms, cry “I'm done!” and pass out on your desk, lobbing your forehead directly into the 
keyboard. Here's our project goal:

“Design an interactive, third-person scene where some entity will run around a room.”

Also known as “A Day in My Life.” It sounds stupid, but think of the subject areas we 
should cover to complete this primitive scenario:

• Setting up a development environment • Camera movement
• Map building • Collision detection
• Model building • Model interaction
• Animation

Thanks To

Thanks to Jorrit and Sunshine for Crystal Space. I encourage everyone to donate early, 
donate often to the project. Lego's aren't free, people.

Thanks to the entire Blender3d crew for the freedom that Blender now enjoys. Buy all 
their books. They make great gifts.

Thanks to Gregor, Jiba and Bjørn for their respective Blender conversion tools.
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Starting Out

What you should already know

You should already know C/C++ and be very comfortable with an object-oriented 
architecture. A working knowledge of structs, classes, dereferencing pointers and memory 
allocation is a must. You also need to be fairly comfortable with running command line 
scripts and whatnot.

Some artistic talent is helpful, but not altogether necessary. Hell, I made it this far.

Getting your toolkit together

Before you can start your Crystal Space hackin', you need a suite of software. Here's a list 
of the items you should bring to class. Note that the majority is open source and freely 
available on multiple platforms.

• The latest version of the Cal3d libraries from CVS. This tutorial will use the most 
recent version checked out at 5/27/2004.

• The latest version of Crystal Space from CVS. This tutorial will use the most recent 
version checked out at 6/5/2004.

• The latest version of Crystal Entity Layer, or CEL, from CVS. This tutorial will use 
the version as of 6/5/2004.

• Blender   2.3.6  . The scripts we'll use require this version or later.

• The application blender2cs, used for converting our Blender objects to meshes (in this 
case, maps and static objects).

• The GIMP. This application allows us to create textures and images for use with 
Blender and Crystal Space.

• A C/C++ development environment for your platform, such as Visual C++, Visual 
Studio, KDevelop, Emacs, Borland C++, a text editor and a copy of gcc, whatever 
tickles your respective fancy.

Recommended items

There are a few items that, although not completely required, I've found pretty helpful:

• The Official Blender 2.3 Guide. It covers version 2.31 and is an invaluable way to start 
learning about animation, materials, lighting, mesh design, etc. Having a nice, glossy 
book can be extremely helpful.

• I hear both Grokking the GIMP and GIMP: The Official Handbook are nice lil' books 
to learn about working with GIMP. I haven't read 'em, but as far as books go, they are 
definitely some of the bookish books out there. They're available in both online and 
printed form.

• Salada Green Tea  . Stay wired... in a good way.

• Somewhat recent hardware. A P4 2.4 GHz or an Athlon XP 2100+ with 512 RAM and 
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a modest 3D accelerator (GeForce 4Ti or similar ATI hardware). Some shader effects 
in Crystal Space need more modern cards, but we won't be covering shaders in this 
tutorial.

• A high resolution monitor. 1280x1024 is a workable resolution – the more the better 
when dealing with Blender workspaces. Multiple monitors may or may not be a big 
help, since some video cards can have problems doing multi-monitor displays and 3D 
acceleration.

• SuSE Linux 8.2 Professional or better. I'm not being an evangelist here; I just think 
this is the easiest platform for your primary development. You can port to Windows 
after originally writing of Crystal Space applications in Linux - so you don't have to be 
so concerned with your development environment matching your target environment. 
The main reason I like Linux development is because so much of the distribution is 
geared towards allowing extensible compilation, development tools, debugging, 
memory allocation tools and automation. Considering that Linux distributions rely on 
the fact that source is readily available for people to compile and build themselves, 
they make it very easy to develop, compile and test code in a myriad of ways.
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Homework Assignment #1
This is the biggest hurdle to overcome: setting up your dev environment, installing all the 
apps, getting the first app compiled. Use the below documentation to compile Crystal 
Space and send it through a test run.

1. Build and install   Crystal Space

2. Run the Crystal Space Walktest application
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Build a Map from Scratch
We aren't even going to start with Blender on this one... our first level is going to be done 
entirely by hand. Map data is stored in XML format, then usually archived to a smaller 
size later. This can make map loading potentially slow, but very extensible and easy to 
modify.

Let's start by sketching out what we want our map to look like in three-dimensional 
space. It should just be a small box, 20x20x201. The intersection of the x and z axis will 
be the center of our floor, so the width dimensions will be from -10 to 10, depth from 10 
to -10 and height from 0 to 20.

Creating textures

We'll also need a texture to cover our walls with. Any 64x64 pixel image will do – I fired 
up GIMP and created a really quick texture using a default pattern, then saved it as 
amethyst.jpg.

Creating the World Map

Now that we have some paint, we need some walls. A Crystal Space map file is just an 
XML document, so fire up your handy ol' text editor and start typing. Create a file called 

1 Note we don't really have a unit of measurement... it's largely subjective. You'll get a feel for what a unit 
is after running around in a few maps. Jorrit's rule of thumb is that 1 unit in CS equals 1 meter. Awith 
Blender 2.35 player character might average 0.6 units wide, 0.3 deep and 1.75 high.
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“world” and type the following headers:

<world>
  <plugins>
    <plugin name="thing">crystalspace.mesh.loader.thing</plugin>
  </plugins>
This tells the Crystal Space engine to load up the thing plugin, used for creating thing 
meshes. Things are basically only used for really big structures (such as maps).

Now that we have our plugin loaded, we'll need to add:

  <textures>
    <texture name="amethyst">
      <file>amethyst.jpg</file>
    </texture>
  </textures>
  <materials>
    <material name="defaultWall">
      <texture>amethyst</texture>
    </material>
  </materials>
This loads our graphics file and gives it an alias – in this case the texture in file 
amethyst.jpg is saved as texture amethyst. The texture is then loaded into a material for an 
object, in this case we load the amethyst texture as the material defaultWall. These 
references make it easy to re-use textures as necessary and quickly change paths or 
textures if we need to.

Next up let's send the engine a command to clear the screen and the z-buffer:

  <settings>
    <clearzbuf>yes</clearzbuf>
    <clearscreen>yes</clearscreen>
  </settings>
After this we set the camera's origin – where we initially spawn when the map is loaded. 
We'll lauch a few feet from the floor towards a corner of the room:

  <start name="Camera">
    <sector>Scene</sector>
    <position x="5" y="5" z="-5"/>
  </start>
Easy so far. Now let's create our room's geometry.

Crystal Space divides maps into sectors for more efficient loading. Sectors can be joined 
together by portals, which basically “teleport” you from one sector to the next.

We'll just have a single sector, since our room is simple and small. Let's define it as 
“Scene” (this will have special meaning when we start doing Blender stuff).

  <sector name="Scene">
Now let's place a light towards the top of the room. Otherwise you'll stumble around until 
you kick the cat:

    <light name="Lamp">
      <center x="0" y="15" z="0"/>
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      <color red="1" green="1" blue="1"/>
      <radius>30</radius>
    </light>
Now we actually define the planes surrounding us. We'll call it “Room” and list its 
individual vertexes. 

    <meshobj name="Room">
      <plugin>thing</plugin>
      <params>
        <v x="10" y="0" z="10"/>
        <v x="10" y="0" z="-10"/>
        <v x="-10" y="0" z="-10"/>
        <v x="-10" y="0" z="10"/>
        <v x="10" y="20" z="10"/>
        <v x="10" y="20" z="-10"/>
        <v x="-10" y="20" z="-10"/>
        <v x="-10" y="20" z="10"/>
Excellent. We've called our thing mesh plugin and given it our list of eight vertexes, one 
for each corner of the box we'll launch our camera into. Now we need to paint our walls... 
otherwise it's hard to see 'em.

We'll be using UV texture mapping for the walls, mainly so we can become familiar with 
the concept once we start using Blender. The “uv” part comes from the two dimensions of 
our texture. Since the coordinate spaces x and y are already used by our object, we'll refer 
to the horizontal and vertical dimensions of our two-dimensional texture as u and v.

Below you can see a list of vertexes which are then mapped to the texture we created. The 
u and v coordinates are between 1 and 0 – so below we are mapping the whole texture to 
a given face.

        <p>
          <v>1</v>
          <v>2</v>
          <v>3</v>
          <v>0</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
        <p>
          <v>7</v>
          <v>3</v>
          <v>2</v>
          <v>6</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
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        <p>
          <v>5</v>
          <v>1</v>
          <v>0</v>
          <v>4</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
        <p>
          <v>5</v>
          <v>6</v>
          <v>2</v>
          <v>1</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
        <p>
          <v>7</v>
          <v>4</v>
          <v>0</v>
          <v>3</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
        <p>
          <v>4</v>
          <v>7</v>
          <v>6</v>
          <v>5</v>
          <material>defaultWall</material>
          <texmap>
            <uv idx="0" u="1" v="0"/>
            <uv idx="1" u="1" v="1"/>
            <uv idx="2" u="0" v="1"/>
          </texmap>
        </p>
      </params>
Let's close up all our tags!

    </meshobj>
  </sector>
</world>
with Blender 2.35And believe it or not, that's it! Save the file in the same directory your 
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texture exists.

Testing the Map

Crystal Space ships with walktest, an application that loads up maps and lets you jaunt 
through them. Hopefully you should have Crystal Space up and running and have already 
run walktest. Generally if you have any problems with Crystal Space, the first response to 
your inquiries is “does walktest run?” Take a moment to run and walkthrough walktest to 
see what its like.

We're going to load the map in walktest using a few commands. Because we need 
walktest to recalculate lightmaps for us (since this is a new map), we need to use the 
-relight command. This will give us a lightmap cache that we can reuse later. We'll also 
run -verbose to printout lots of debug info should we need it.

If your machine doesn't have hardware acceleration enabled (i.e. you're using Xinerama 
like me) you'll need to add the parameter -video=software to the command as well.

Let's say the map and the texture are in my current directory. To load the level up and 
walkthrough it, type

walktest -relight -verbose .

This should load your map and allow you to run through it2

2 The 0 key will launch a rocket from the camera's location and explode upon impact with a wall
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Homework Assignment #2
Now we're gonna use Blender to help us with the level building process.

1. Read the Introduction to Blender  3  , but skip “Your First Animation in 30 Minutes” if 
you like

2. Complete Part 1 of the blend2cs tutorial  4   with Blender 2.35

3 http://download.blender.org/documentation/html/book1.html  
4 http://www-poleia.lip6.fr/~degris/blender/tutorial/  
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Build a Map with Blender
Now we'll construct the same map, except this time with Blender. One word of warning 
when using Blender to create Crystal Space maps: don't rotate or scale meshes in object  
mode! Instead use edit mode to scale and rotate selected vertexes. Failure to do so can 
cause some wacky texture warping and shearing5.

Creating the Box

First we need to create the 20x20x20 box. Go to Add→Mesh→Cube to add a cube at the 
current cursor. Make sure you're in edit mode, then select all the vertexes of the cube; you 
can do this using box select (B key) or doing a select all (A key). After that, scale your 
cube (using the S key) to be roughly 20 units high, wide and deep. Use the CTRL key to 
snap your vertexes to the grid – it can help you keep things evened up. Bear in mind the 
fine grid lines mark off single units, the bold grid lines mark off ten units.

To move your box above the x and z axis, grab your vertexes (G key) and move them up 
toward the top. Switch top, side, front and free view modes to ensure you have a nice 20-
unit cube.

Next we add our texture to the cube. Switch to the material screen (drop down SRC list at 

5 From the Crystal Core Creating Art article on the Crystal Space site: “Warning! In Blender it is best to 
scale and rotate objects in edit mode (by scaling/rotating all vertices) instead of directly on the object. 
The reason is that in the latter case blend2cs will generate a scale/rotate in the world file on the mesh 
object. In case of the rotate this is not that bad but it is illegal to scale objects in CS using <move> 
(using <hardmove> is ok). If you already scaled objects directly you can use 'Apply Size/Rotation' (ctrl-
A) in blender to fix this. This even works with all objects selected at once.”
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the top of the screen). In the toolbar on the right, switch to the UV editor (Shift-F10) then 
go to Image→Open... to open the file dialog. In the dialog window, ensure that you have 
the “Relative Paths” button selected6. After that, open up your image file into the UV 
editor.

Jump into UV Face Select mode. Select each face of the cube and add the texture to it by 
selecting it from the drop-down texture list.

Switch back to model view. Right now our cube faces are pointed outward – so when 
we're inside the cube we'll see nothing but infinite space. We need to flip them around so 
we can see them inside the cube. It's like the faces of a playing card – only one side is 
printed, the other is just random crapola.

Go to edit mode, open up the buttons menu and switch to the editing layout (F9). Click 

6 Versions after 2.34 will have a very handy “Relative Paths” button in the file open dialog. This will 
allow Blender files to be much more portable, since currently all file paths are stored as absolute 
pathnames. For example, if you open an image in /home/user/image.png, save the .blend file and move it 
to another computer, the image on the other computer must also be located at exactly  
/home/user/image.png. Newer versions released will remember where the file was located relative to 
the .blend file instead, allowing a directory to be easily shared and moved from workstation to 
workstation.
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on “Draw Normals” and increase NSize from 0.100 to 1.000. Note lines are pointing 
outwards – that is the faces are pointing outward. Select all the nodes, then click on “Flip 
Normals.”

Make sure to place a camera object and a light within our cube as well. Both should be 
placed towards the center of the cube.

Exporting the Blender File

Use blender2cs to export our Blender level to a Crystal Space XML world file:

blender2cs tutorial.blend -o world

Take a look at the resulting world file that's produced. Looks pretty similar to the one we 
created by hand, doesn't it? Aside from some rounding, the values should be fairly 
similar. Load it just as we loaded the first world file, using

walktest -relight -verbose .

That's it! The camera object we placed in the center of the cube has become our start 
point, the light object we placed in the cube was translated into a light source for the map, 
and the inverted faces of our cube were mapped into vertexes for our room.

HowTo Build with Crystal Space and Blender - Build a Map with Blender

Illustration 4Flipping Normals



Homework Assignment #3
1. Complete Part 3 of the blend2cs tutorial  7  .

2. Expand your map into something more creative and sizable – we need room for some 
objects to be tossed around.

7 http://www-poleia.lip6.fr/~degris/blender/tutorial/  
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Object Library Loading in Maps
In refining your custom map you might have had several reoccurring objects (such as 
furniture) that would be easier to load from a single source instead of copying-and-
pasting the object multiple times. This can be done by creating an object in its own .blend 
file and then referencing it within Blender.
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Homework Assignment #4
We're going to start building character models, so it's time to:

1. Build   and install Cal3d libraries

2. Complete “Your First Animation in 30 Minutes” in the Introduction to Blender  8   
documentation you read earlier

8 http://download.blender.org/documentation/html/book1.html  
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Building a Simple Character Model
In the last tutorial I authored we created CanMan – an animated character made from 
cylinders. This time we're going even simpler: BoxMan!

Creating the Mesh

First we need to insert a cube into Blender. Make sure it sits directly on the x and z axis 
so the center of the bottom face is at 0, 0. Select only the top four vertexes, then extrude 
the face to create another cube attached to the top. Do this once more so the mesh is 
constructed of three extruded cubes.

Once the box mesh is created, we need to create a set of armatures to define the mesh's 
skeleton. Center Blender's cursor at 0,0,0, go into object mode and click on 
Add→Armature to insert the first bone. Have it go about halfway up the mesh, then 
single-click to finish the first armature and start a second, connected one. Stretch this one 
up to the top, single-click to anchor it then right-click to finish our skeleton.
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Go to the editing window (F9) and click on “Draw Names.” This will show the default 
Blender names assigned to our bones – usually “bone.001” or the like. We want to 
rename them to “Head” and “Foot,” so in object mode select the armatures, switch to edit 
mode, then hit Ctrl-A to select all of the bones. As long as you're still in the editing 
window you should see a list of “Armature Bones.” Rename the selected bones listed 
there to “Foot” and “Head.”

Now we need to link the mesh and the skeleton together. Switch back into object mode. 
Right-click on the mesh, then Shift-right-click on the armature inside. This should turn 
the outer box mesh magenta and the inner armature light pink. Hit Ctrl-P to make the 
mesh the parent object of the armatures. Select “Use Armature” and “Create from Closest 
Bones” when prompted.

HowTo Build with Crystal Space and Blender - Building a Simple Character Model



When we selected the “Create from Closest Bones” item in the parent menu, we told 
Blender to guess what vertexes should belong to which bones. Let's see how smart 
Blender was.

Stay in the editing window, select your box mesh in object mode, then switch to edit 
mode. Make sure none of your vertexes are selected (they should all be magenta). Take a 
look at the “Link and Materials” section: you should see a menu called “Vertex Groups.” 
They probably have the same generic names your armature did at first, such as “Bone.
001.” Select the first one on the drop-down list, then click on “Select.” The vertexes 
assigned to this group are now selected and highlighted on your mesh. If Blender 
guesstimated correctly, there should be a vertex group for the top half of the mesh, and a 
second group for the bottom half of the mesh. If it goofed and only did portions of the 
vertexes, use box select (B key), select the vertexes and then hit “Assign” to assign the 
selection to a group. Every vertex in your mesh should be assigned to a group.

Once you're happy with the vertex group assignments, rename the vertex groups to match 
the bone names (i.e. “Head” and “Foot”). Bone names and group names must be the same 
to be exported correctly  9  .

9 If you can't tell, I underlined the two points I forget constantly. The emphasis is as much for my 
edification as it is for yours.
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Now that we have the vertex groups assigned, a skeletal structure in place and a mesh 
constructed we can work on exporting the model to Cal3d format.

Exporting the Model from Blender into Cal3d Format

Go to File→Export→Cal3D Exporter in the Blender file 
menu. Make sure that “Export for Soya10” is selected 
since we need to transform the coordinate system from 
Blender to Crystal Space. Set the “Export to:” value to be 
the directory you want the cal3d files to be dumped into. 
The “File prefix” value will be a name appended to the 
beginning of each file name, so set it to “boxman” for 
now. If we need to eventually scale the image down or up 
(we've made it to large/small in Blender) we can do so 
with the “Scale” bar.

Once all the variables are set, click “Export” and 

10 This script was originally written by Jiba for his Python 3D engine called “Soya 3D.” Take a look at 
http://home.gna.org/oomadness/en/
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boxmanCube.cmf and boxman.csf should pop up in your “Export to” directory. If you get 
an error, double check and make sure all your vertexes belong to a vertex group and the 
vertex group names are the same as the bone names. Also ensure no “.” characters exist in 
the bone or vertex names11.

Now we need to create a Crystal Space cal3d file to describe our model as a sprite. Create 
a new file called boxman.cfg with the following contents:

<meshfact name="boxman">
   <plugin>crystalspace.mesh.loader.factory.sprite.cal3d</plugin>
   <params>
        <scale value="0.25" />
        <mesh file="boxmanCube.cmf" name="body" material="skin" />
        <skeleton file="boxman.csf" />
    </params>
</meshfact>

We should now have something to test out! Launch the app viewmesh from your Crystal 
Space installation, click somewhere in the window and select “Load Mesh.” Open up 
your boxman.cal3d file. You should now see an untextured (probably black) box standing 
in the middle of the room that looks like your newly created mesh. If you notice errors 
being spewed out to the console when attempting to load the mesh, make sure your cal3d 
file has the correct filenames for each cal3d resource to load. There is also an occasional 
bug in the script where skeletal information isn't exported; if you see “Could not load 
cal3d skeleton file” errors then close the Cal3d export window and restart it.

11 To avoid glitches in the export process, it's a good idea to quit the script and restart it for each export.
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Animating the Model

Now we need to add a couple of actions to our model: a walking animation and an attack 
animation. Considering that our mesh is just a big box... most will likely look stupid. But 
that's what first models are for: looking stupid. We can get creative later12.

Let's do the walk action first. Make sure you're on the first frame of animation in Blender 
– this is indicated by the button at the top of the edit buttons that shows “< 1 >” by 
default, meaning it's on the first frame. Jump into pose mode and pose what would be the 
first frame of a “walk cycle.” All you really need to do is grab the foot armature and pull 
it back slightly. This will tilt the whole mesh backwards. Make sure all your bones are 
highlighted (you can use the A key to deselect all vertexes, then A to re-select them) and 
hit the I key. Select “LocRot.” when prompted; this will save our first frame of animation. 
Copy the current pose into the buffer by selecting Armature→Copy Current Pose (or use 
the copy pose button). We'll need it at the end of our animation cycle.

12 I remember reading a tutorial on creating Doom levels back in the day... it had a quote I'll never forget: 
“Your first level will always suck.” That's the point of “first levels” existing. You'll have this big, lofty 
goal that you'll try to make happen on your first go-'round but it will turn out looking like a two year old 
drew it with a crayon in his mouth. Yet if you follow it through to its bitter, ugly end then you get the 
“first level suck” mojo out of your system. If you don't see things through and keep scrapping your first 
levels (or applications or models or whatever) before you finish, you'll be stuck in a cycle of crapola. 
Realize your first vision, burn it to a CD, then start again.
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Jump to the 11th frame of animation. Here we'll do much of the same except we'll tip our 
mesh forwards. Select your bones and LocRot again.

Now go forward to the 20th frame. We'll make our last pose the same as the first pose so 
the animation is nice and smooth – select Armature→Paste Pose (or use the paste pose 
button) to paste the pose we copied to the buffer into the current frame. Select bones and 
LocRot once more.

Switch to the scene menu (F10) and take a look at the “Anim” group. We need to tell 
Blender what our first and last frame of animation is – the default is something like 250 
frames (way more than our 20 frame walk cycle). Change “Sta” to be 1 and “End” to be 
20 – this way Blender restarts the animation after 20 frames.

Let's preview our animation in Blender. Hit Ctrl-A and the animation cycle should start in 
your active mesh window. Hit Esc to stop the animation cycle.

Export your model again using the Cal3d script. This time you should have a 
boxmanAction.caf file sitting in your data directory. Add a corresponding entry in your 
boxman.cal3d file right after your “skeleton” tag to register your newfound action:

<animation file="boxmanAction.caf" name="Walk" />

Load your cal3d model into viewmesh once again. You'll see the same object as before, 
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except this time we'll have an extra menu item to select from. Click on the viewmesh 
window to bring up the menu, then select Set Action Loop→Walk. This will launch our 
new animation! You should see a box wobbling in the middle of the room.

Jump back into Blender and go to the Action Editor window. Rename “Action” to 
“Walk.” Jump into the IPO Curve Editor and rename “Action.Foot” to “Walk.Foot” and 
“Action.Head” to “Walk.Head” as well. Re-export to cal3d. Notice that your 
boxmanAction.caf isn't exported? Instead you get boxmanWalk.caf. By renaming the 
prefix to the actions in the Action and IPO Curve Editors we can separate out our model's 
animations.

Let's create a new attack animation. Go into the Action Editor and create a new action. 
Rename it “Attack.” Once its selected, create an attack animation just like we created a 
walk animation, except more... attack-like. My animation goes like this:

Frame 1 Mesh is centered and still

Frame 10 Head bone rotated slightly backwards

Frame 15 Head bone rotated all the way forward

Frame 20 Copy of Frame 1
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Once your animation is done, jump into the IPO Curve Editor and make sure the curves 
are renamed to match your action (i.e. Attack.Foot and Attack.Head). Export your model 
to cal3d once again and use these lines for your two animation tags in the .cal3d file:

<animation file="boxmanWalk.caf" name="Walk" />
<animation file="boxmanAttack.caf" name="Attack" />

Save the file and load the boxman.cal3d file up in viewmesh again. You should be able to 
switch between the “Walk” animation cycle and the “Attack” animation cycle.

Types of Actions in .cal3d Files

We need to delimit which actions in our cal3d file is for travelling, which is for attacking 
and which are for idle loops. Take a look at plugins/mesh/sprcal3d/persist/dwarf.cal3d  in 
your Crystal Space source directory – it gives examples for most of the attributes 
supported by Crystal Space's Cal3d plugin.

Let's change our actions to be marked as “travel” and “action” types. Our current file 
looks like:

<meshfact name="boxman">
   <plugin>crystalspace.mesh.loader.factory.sprite.cal3d</plugin>
   <params>
      <scale value="0.25" />
      <mesh file="boxmanCube.cmf" name="body" material="skin" />
      <skeleton file="boxman.csf" />

<animation file="boxmanWalk.caf" name="Walk" />
<animation file="boxmanAttack.caf" name="Attack" />

    </params>
</meshfact>
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Let's add properties for our animations, such as:

<animation file="boxmanWalk.caf" type="travel" name="Walk" base_vel="2" 
min_vel="0" max_vel="3" />
<animation file="boxmanAttack.caf" type="action" name="Attack" 
idle_pct="33" />

Reload the boxman.cal3d file into viewmesh. Notice that “Attack” is no longer in the 
“Set Action Loop” menu? It has been moved to “Overrides.” The attack animation 
shouldn't loop for a character like a walk animation would; walking is a repetitive motion 
that can be displayed by an animation loop. Attacking is a single action that would 
interrupt the current action – for example, the boxman walking towards an opponent and 
trying to headbutt them.

First fire up the walk animation in viewmesh, then go to Overrides→Attack. Notice how 
the walk animation breaks, switches to the attack animation and then switches right back? 
This is how it should work in our application logic as well.

Adding Textures to Character Models

To map a texture onto our mesh and make it look nice and pretty, we'll need to use 
Blender's UV texture editing.

First we need to generate a UV template. To do this, open up the UV Editor in Blender. 
Select our box mesh, then go into UV face select mode. Use the A key to select all the 
faces in the model, then hit the U key to perform the UV mapping. Select “Cylinder” 
from the pop-up menu.

We'll now have a really long mesh in the UV Editor window. It's rather uneven as well. In 
the UV editor, use box and vertex select to move around individual vertexes and even out 
the UV mapping. You should end up with a uniform grid for your model's UV map.
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Illustration 13Initial UV Map Illustration 14Revised UV Map

Start up Gimp and use it's File→Aquire→Screen Shot function to take a screen shot of 
our UV window. Using the “Select Contiguous Regions” tool (Z key) remove the dark 
portions of the image. Crop the image down so you only see the UV map. The result 
should be a black, flat, wireframe representation of our mesh. 

Once we have our UV template, we can start painting a texture on top of it. It can be 
anything you want – a face, another Gimp pattern, colors for each face, etc.

I opted for... erhm... surrealism. Save your image as a JPG in the same directory as 
your .blend file.
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Illustration 15The blank UV template Illustration 16My surreal UV map

Open the image you created in Gimp over top of the UV template by opening up the 
UV/Image Editor and clicking on Image→Open13. Once your image loads, you may need 
to scale the UV map so it fits over your new image. Make sure all the edges and corners 
match up, then view the textured result by switching a view window to a textured display 
mode. You may need to move the vertexes around even further to get the image you had 
in mind square on the mesh.

13 Don't forget to use the “Relative Paths” button!
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Now let's export again. This time our “Image prefix” value nees to be “this/” instead of 
“textures/” in the Cal3d export window. Make sure the image is in the same directory as 
your cal3d files.

Next we're going to add an entry for our image in the boxman.cal3d file. In the mesh tag, 
let's change the material attribute be the Crystal Space VFS14 path to our image. In this 
case, the tag would look like:
<mesh file="boxmanCube.cmf" name="body" material="/this/uvtemplate.jpg"/>

Load up boxman.cal3d one more time in viewmesh. Animate away... we've created our 
first Cal3d sprite for Crystal Space!

14 See the Crystal Space documentation about VFS paths. Right now we're using the VFS path /this/, which 
Crystal Space interprets as the current working directory.

HowTo Build with Crystal Space and Blender - Building a Simple Character Model

Illustration 17Our UV mapping in Blender



HowTo Build with Crystal Space and Blender - Building a Simple Character Model

Illustration 18Our boxman!



Homework Assignment #5
1. Setup your development environment for:

• KDevelop in KDE  

• Microsoft Visual C++ 6  

• Microsoft Visual C++ 7  

• Or just in general  

2. Complete tutorials 5.1-5.4 within Crystal Space's documentation to figure out how to 
build your first application, load a sprite and load a map.

3. Read section 5.8.1 in the Crystal Space manual about smart pointers

4. Spend some time spiffing up your map and character model. We'll be using them on an 
ongoing basis in our tutorial, so create something big to walk around in and a creature 
of your own creation.
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Creating a Stand-Alone Application
So far we've used walktest and viewmesh to load the entities we've created. Now we need 
to develop our own application that will load our map and place the character model 
inside.

The design of our application should be object-oriented whenever possible. For ease of 
understanding, however, we're going to start by adding code then object-izing it later. 
Maps, characters and entities should exist as structures containing meshes, properties and 
methods that govern them. No details about maps or characters should be stored in the 
code itself. Spawn points, animations and entities should be defined by external resource 
files.

Typing out code in book form and having it become somewhat readable isn't easy. For 
convention sake, new code that we're creating is green and italic, previous code that 
we are now removing is red with a strike-through and code that we're just 
reiterating for clarity's sake (but we are not creating or removing) is just preformatted 
text.
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Appendix A: Using CrystalSpace with KDevelop 3.2
KDevelop 3.2 is a very nice development environment written for KDE, an X11 desktop 
environment. Several very useful features can save you a good deal of time and headache, 
including Valgrind integration, Subversion integration, custom development profiles, 
source auto-completion, automatic generation of build files... the list goes on.

The current version of CrystalSpace documentation is a little sparse when it comes to 
KDevelop integration, and it covers an older version that doesn't exactly translate over. 
Plus, adding CEL on top of the build environment can make things a little trickier.

Building Debug and Optimized Installations of CrystalSpace

To get a good development environment working, we'll first need to build CrystalSpace 
and CEL using the appropriate configuration flags. We'll want two different types of 
builds: one with extra debugging info enabled, the other optimized for speed.

First, download the versions of CrystalSpace and CEL that you'll want to be working 
with, as outlined in their respective sections of this document. Make sure that your build 
goes successfully and that you can run walktest and celtst for CrystalSpace and CEL. 
Don't install the packages just yet – just build and test them. I'm assuming you're doing 
this in a directory such as $HOME/CrystalSpace.

Next we'll need to configure two types of builds for each package: one for testing and one 
for “optimized” builds. The build process is the same for each, except we'll be passing 
some additional files to the configure script.

In both the CrystalSpace and CEL home directories, run the following command to 
configure your environment:

./configure -–enable-debug -–enable-extensive-memory-debugger –-
prefix=/opt/CrystalSpace/debug
This will build a version that enables additional debugging info, sets additional asserts to 
catch errors early, and doesn't do as many compile-time optimizations so code can be 
more easily backtraced. It also catches common memory errors – so you can hopefully 
diagnose the problems before they become something huge.

Create the directory /opt/CrystalSpace/debug, then build and install this configuration of 
CrystalSpace and CEL. 

Next, we'll need to build an optimized version of CrystalSpace and CEL. This will enable 
some compile time optimizations and remove debugging code so things execute as 
quickly as possible15. In both the CrystalSpace and CEL home directories, run the 
following command to configure your environment:

./configure –-prefix=/opt/CrystalSpace/optimized
Create the directory /opt/CrystalSpace/optimized, then build and install this configuration.

15 Sometimes a bug will manifest itself with an optimized build of CrystalSpace but work just fine with a 
debug build. This often happens due to problems with memory management or thread allocation – 
unfortunately they're often tedious to debug. There's not a whole lot you can do, aside from inserting a 
bunch of printf's to trace the code, then running a profiler to perhaps find the source.
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Setting Up a New Project in KDevelop

Next we'll need to start a new project in KDevelop. Open up KDevelop and start a new 
project using the C++ “Simple Hello world program.” Alter your license and source 
templates as need be, then finish your configuration and go to the main project window.

Here we'll need to set up our development environment. Go to Project→Project Options 
in the project window, Then click on “Configure Options.” The “Configuration:” drop-
down box should have “default” listed as the currently selected development 
configuration. From here, we'll add the following info:

General Tab:

Configure arguments:

Here I put architecture-specific arguments to target my specific machine. Since 
I'm running an Athlon XP, I just use the i686 targets such as:

--host=i686-linux --build=i686-linux –target=i686-linux
Linker flags:

Here we put the script that generates the CrystalSpace and CEL linker flags for us. 
Be sure and use the backtick mark ` since we're executing files and passing along 
their output, not quoting them.

`cs-config --libs` `cel-config –lflags`
Environment Variables:
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Add environment variables, including the home directory variables for CEL and 
CrystalSpace. We'll also need to add the path to cs-config and cel-config to our 
PATH environment variable. We're pointing to the place where we can 
build/rebuild CrystalSpace and CEL to our whim – not our static debugging or 
optimized installations.

CRYSTAL $HOME/CrystalSpace/CS16

CEL $HOME/CrystalSpace/cel

PATH $PATH:$CRYSTAL:$CEL

C Tab:

Compiler flags:

Again, automatically generated for us by our config scripts.

`cs-config --cflags` `cel-config --cflags`
C++ Tab:

Compiler flags:

Again, automatically generated for us by our config scripts.

`cs-config --cxxflags` `cel-config --cflags`

Once we hit “OK” KDevelop will ask if we want to re-run configure... say “Yes.” Now 
we have built a development environment off of our rough, rebuildable CrystalSpace 
installation. This will be the default one we can use – it can be tweaked, rebuilt and 
updated as necessary. So long as we don't perform another install, our optimized and 
debug versions stay intact.

Build one of the CEL tutorial apps (such as celtest) in our new development environment. 
You can just move over the source from cel/apps/celtest, copy over CEL's vfs.cfg so mesh 
data loads correctly, then try to compile and run it from scratch. Make sure everything 
runs smoothly.

Building a Optimized Configuration

We'll do the same thing over again, this time with the “optimized” configuration selected 
in the drop-down menu.

General Tab:

Configure arguments:

Architecture-specific arguments

Linker flags:

`cs-config --libs` `cel-config –lflags`

16 Don't forget that I'm assuming you did your initial build in $HOME/CrystalSpace. Depending on where 
you downloaded/built your CrystalSpace and CEL packages, this path may be different.
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Environment Variables:

CRYSTAL /opt/CrystalSpace/optimized/CS

CEL /opt/CrystalSpace/optimized/cel

PATH $PATH:$CRYSTAL/bin:$CEL/bin

C Tab:

Compiler flags:

`cs-config --cflags` `cel-config --cflags`
C++ Tab:

Compiler flags:

`cs-config --cxxflags` `cel-config --cflags`

Hit “OK” and re-run configure. Perform a Build→Clean Project, then rebuild and re-run 
our test application. Verify that things work as expected.

Building a Debugging Configuration

One more time, this time with the “debug” configuration selected in the drop-down menu.

General Tab:

Configure arguments:

Here we're going to ditch our architecture-specific tab and tell KDevelop's 
configure script to give us all the debugging info it has.

--enable-debug=full
Linker flags:

`cs-config --libs` `cel-config –lflags`
Environment Variables:

CRYSTAL /opt/CrystalSpace/debug/CS

CEL /opt/CrystalSpace/debug/cel

PATH $PATH:$CRYSTAL/bin:$CEL/bin

C Tab:

Compiler flags:

`cs-config --cflags` `cel-config --cflags`
C++ Tab:

Compiler flags:

`cs-config --cxxflags` `cel-config --cflags`
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Hit “OK” and re-run configure. Perform a Build→Clean Project, then rebuild and re-run 
our test application. Verify that things work as expected.

Final Notes

We now have a working build environment for our CrystalSpace apps. Switching 
between configurations will help us more easily debug our code, as well as test out new 
CrystalSpace releases before installing them.

It's a good idea to take advantage of KDevelop's native Subversion support – using some 
means of a source code management tool helps immensely. Even if you're just writing an 
app to learn CrystalSpace or just typing up a quick proof-of-concept application, being 
about to roll back to your last known good build or looking at the difference between a 
working and historical file can save tons of time.
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Appendix B: Map Building with GtkRadiant
Before proceeding, complete the introductory tutorial within GtkRadiant's documentation.

Creating a New Map

Now let's build our map. Create a directory named “data” within the base project 
directory you just created. This should be the same directory your executables will be 
created. For me, it's the directory cstutorial/, so I'll create a separate directory 
cstutorial/data. This is where we'll be placing all of our non-code items.

During your installation of GtkRadiant it should have installed a quake3 directory 
alongside it. This gives us some basic Quake III Arena textures we can use to experiment 
with, but we want to import our own textures straight from Crystal Space. For no 
particular reason, let's take the mystone2.gif from crystal/data/standard.zip and put it in 
the data/ directory we just created.

Problem with GtkRadiant is that we absolutely have to have our texture files stored in 
RGB TGA format. That's where our friend the GIMP comes in handy; fire up GIMP and 
open the mystone2.gif file in our data directory. Right-click on the file, then go to 
“Image->Mode.” Click on “RGB,” this will convert the file to a red/green/blue image 
format. 

Next right-click again and go to “File->Save As” to save our new file. In the drop-down 
menu for file extensions, select “TGA” and save the file. We should now have a new 
image called “mystone2.tga.” 
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Now we need to place the .tga file within a Quake .pk3 file. This isn't nearly as hard as it 
sounds – a .pk3 file is just a Zip file with a specific directory structure within it. Within 
your data/ direcory create a subdirectory named textures/crystal. Move your mystone2.tga 
file into the textures/crystal17 directory. Zip the entire textures direcory into a file called 
“mytextures.zip.” Rename it “mytextures.pk3.” If you open it up now in WinZip or Gzip, 
you should see the following contents:

textures/crystal/mystone2.tga

Place the mytextures.pk3 file into the quake3/baseq3 folder that GtkRadiant created 
during installation. Once you launch GtkRadiant (close it down and re-launch if it's 
already open), it should automatically notice our new texture pack and load it into the 
textures list.

17 Bear in mind I'm a Linux guy, so all my directories have front slashes ('/'). If you come from the 
Windows side of things (aren't you glad I wasn't a jerk and called it “M$ Windoze”) then substitute my 
front slashes for backslashes ('\').
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Now that we have our Crystal Space texture loaded, we need to create a room. Just as you 
did in the Radiant tutorial (remember that?), we'll start by just creating a basic box. First, 
select Textures->crystal and click on the mystone2 texture that pops up. It needs to have a 
red box around it.

Now let's create a new room by just drawing a box around the camera in our introductory 
z-axis view:
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If you go to the y-axis view, you'll notice our box is a little flat. Expand it out so we're in 
an actual box the camera can fit in.
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Once you strech out the box, hollow it out using the “Hollow” tool. If we had the 
mystone2 texture selected ahead of time, the walls should automatically have that texture.

We'll need to specify a place for our camera to spawn. Right-click somewhere within 
your box and select “info->info_player_start” to insert a spawnpoint. Move the box 
representing the spawnpoint onto the ground and a reasonable place on the map. Switch 
between x, y and z-axis views until you get things in the right place18.

18 Don't place your spawnpoint exactly on the floor – put him a little bit above. Otherwise your camera will 
get glued to the floor.
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Almost done. Now we have to insert a light – otherwise we're not going to see jack squat. 
Open up the entities menu by right-clicking in the box we created and select “light.” Take 
the default values, then place the light somewhere reasonable within the level... just as 
you did for the spawnpoint.

Save your work in your project's data folder as “arena.” This should create a file called 
“arena.map” in your data directory. 
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Converting Your Map to Crystal Space Format

Now that we have our map done, let's convert it to Crystal Space's XML format. To do 
that we will use map2cs, a command-line utility that comes with Crystal Space.

We need to setup certain definitions for the conversion process to refer to. The utility 
map2cs can take in a custom configuration file, so let's create one in data/ called 
map2cs.cfg. It should contain the following:

Map2CS.TextureSettings.pk1 = <path to quake3>/baseq3/mytextures.pk3

Map2CS.General.Scaling = 0.025

Map2CS.General.UseBSP = 1

Map2CS.General.RemoveHidden = 0

Map2CS.General.LightScale=30

System.ApplicationID = Map2CS

Make sure you replace <path to quake3> with the actual path to the quake3/ directory that 
GtkRadiant created for you upon installation. Now let's call map2cs and convert our map 
to a Crystal Space .zip file:
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> map2cs arena.map arena.zip map2cs.cfg19

This will translate our Quake map file and textures to Crystal Space format, then organize 
them all within a .zip file. To check and make sure our map converted correctly, load it 
within the walktest application. This will load our map and place us right were our spawn 
point was. Make sure you're in the same directory as arena.zip, then invoke it with:

> walktest arena -relight

Move the camera around a bit. If you can't get the camera to move, make sure your player 
start position is not touching any walls or the floor. If you need to do any fine-tuning, do 
so now and re-convert.

19 If you get a “command not found” error, make sure the directory that contains map2cs, walktest, etc. 
(usually the bin/ directory within your Crystal Space installation) is in your path.
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